Attempt to set permission attributes on data set but permissions tab does not show users

I am using a standalone instance of Galaxy. I have downloaded a data set successfully and it is in my history. I have another user locally, who is logged in successfully and who shows up in the admin panel as a user. However, when (as user 1, who is an admin) I click on Edit Attributes and then go to the data set’s Permissions tab, this other user does not appear in any of the drop down boxes when I try to assign permissions to them. The only user that I see is myself, for both the “manage permissions” and “access” fields.

Is there some sort of magical configuration ritual that I must perform, in order to make this dataset visible to other users?

1 Like

I should add that I also do not appear to be able to share histories with other users either, and the drop down box to assign permissions simply does not get a match on them or even recognize they are there.

1 Like

Hi @crh

Please see these FAQs: https://galaxyproject.org/support/

Also, please see the prior Q&A at this site. I added the tag “share-or-publish”.

These two posts will likely help the most:

Hi,

From the docs I see:
“For datasets you have created (or were given permissions) you can control what roles can access it. The interface is available on history datasets after clicking the ‘pencil - Edit attributes’ icon and then moving on the ‘Permissions’ tab. Watch animation. Adding additional roles to the ‘access’ permission along with your “private role” does not do what you may expect. Since roles are always logically ANDed together, only you will be able to access the dataset, since only you are a member of your “private role”.

This is what I am trying to do, actually, but when I try to add any users in that panel (datasets/edit in the URL) on the Permissions tab, the only user that is visible is me.

I was able to figure out how to publish a history and then share it with other users, but it appears that the permissions options on actual datasets don’t actually do anything, or can’t be set? What is the purpose of that dialog if other users can’t be added to roles? Is there a global config setting that turns this capability on or off?

ok wait
that panel is talking about roles not users. That’s counterintuitive… anyway, I guess I figured it out, you have to create roles first and then assign them, rather than just assigning permissions to user emails directly. sigh.

1 Like