Error when opening shared history / shared data

A colleague has tried to share a history with me both directly through galaxy and via email link, with all the correct permissions enables. I can see that the history has been shared and I have tried to copy the data into a new history so I can work with it but when I copy it is “locked” (grey with padlock symbol) and I get this error message:

An error occurred while updating information with the server. Please contact a Galaxy administrator if the problem persists.

{
“userAgent”: “Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/13.0.4 Safari/605.1.15”,
“onLine”: true,
“version”: “19.09”,
“xhr”: {
“readyState”: 4,
“responseText”: “{“err_msg”: “HistoryDatasetAssociation is not accessible by user”, “err_code”: 403002}”,
“responseJSON”: {
“err_msg”: “HistoryDatasetAssociation is not accessible by user”,
“err_code”: 403002
},
“status”: 403,
“statusText”: “Forbidden”
},
“options”: {
“parse”: true,
“silent”: true,
“data”: {
“keys”: “rerunnable,creating_job”
},
“emulateHTTP”: false,
“emulateJSON”: false,
“textStatus”: “error”,
“errorThrown”: “Forbidden”
},
“url”: “https://usegalaxy.eu/history/view_multipl/api/histories/a489dab0c2188806/contents/datasets/11ac94870d0bb33af94c6557875877e7?keys=rerunnable%2Ccreating_job”,
“model”: {
“state”: “noPermission”,
“deleted”: false,
“purged”: false,
“name”: “hMADS-shGps2-D14-3_fastq.gz”,
“accessible”: false,
“data_type”: “”,
“file_ext”: “”,
“file_size”: 0,
“meta_files”: [],
“misc_blurb”: “”,
“misc_info”: “”,
“tags”: [],
“history_id”: “a489dab0c2188806”,
“history_content_type”: “dataset”,
“hid”: 18,
“visible”: true,
“model_class”: “HistoryDatasetAssociation”,
“id”: “11ac94870d0bb33af94c6557875877e7”,
“urls”: {
“purge”: “/datasets/11ac94870d0bb33af94c6557875877e7/purge_async”,
“display”: “/datasets/11ac94870d0bb33af94c6557875877e7/display/?preview=True”,
“edit”: “/datasets/edit?dataset_id=11ac94870d0bb33af94c6557875877e7”,
“download”: “/datasets/11ac94870d0bb33af94c6557875877e7/display?to_ext=”,
“report_error”: “/dataset/errors?id=11ac94870d0bb33af94c6557875877e7”,
“rerun”: “/tool_runner/rerun?id=11ac94870d0bb33af94c6557875877e7”,
“show_params”: “/datasets/11ac94870d0bb33af94c6557875877e7/show_params”,
“visualization”: “/visualization”,
“meta_download”: “/dataset/get_metadata_file?hda_id=11ac94870d0bb33af94c6557875877e7&metadata_name=”
}
},
“user”: {
“id”: “b64ec62b32c83b06”,
“username”: “abigail.elliot”,
“total_disk_usage”: 28060130317,
“nice_total_disk_usage”: “26.1 GB”,
“quota_percent”: 10,
“is_admin”: false,
“preferences”: {},
“deleted”: false,
“tags_used”: [],
“last_password_change”: “2020-02-04T09:49:38.992172”,
“active”: true,
“model_class”: “User”
}
}

Hi @abigail.elliot, if the datasets are greyed out it sounds like your colleague shared the history with you but not the datasets themselves. Can you ask them to do it again, making sure to check the box ‘Also make all objects within the History accessible.’?