History is missing

Yesterday I had a project in my account in perfect condition. Today I log in and all I find is: “This history is empty. You can load your own data or get data from an external source”.

What can I do to recover my history?

I am having the same issue. Any solution?

Same thing happened to me this morning… all my histories are empty, but still say they contain items when I look at the list of histories. I tried “resume all paused jobs” and “unhide all hidden content” but nothing has happened.

usegalaxy.eu is currently getting prepared for the update to the latest release of Galaxy.
This causes a bit more issues than expected, and we’re sorry for the inconvenience.

This issue has been dealt with. Sorry again for the inconvenience.

1 Like

Hi, since a few days I have no access to my old workflows (I see the wfs in my wf list but I can’t edit them). Is it also related to the release update? Thanks for your help!

@dfplazag interesting. We haven’t gotten any other such reports, and it’s not all of your workflows but just specific ones, correct?

I would be interested in debugging this case, but for this I would need to share your problematic WFs with a few developers. Simplest way to do so would be to make them temporarily accessible via sharable links. Is that acceptable for you?

Hi, I imported a history from #galaxy.org to galaxy.eu and although it imported without any errors, when I open it all the datasets are empty and shaded in blue saying “This dataset is remote, has not been ingested by Galaxy, and full metadata may not be available”. I checked the exported history from galaxy.org and everything is good there (in"green"). Any ideas why this could be the case?

@Genevieve_Diedericks can you please open a separate issue for this?

It happens with all my wfs, actually. They never fully load in the editing window even though I can still see all the steps under “View”. I can also download all the wfs. Just no possibility of editing. I could share one via link but the problem affects them all. I also logged out and in again, still no editing.

So, can I just share the WF you’re showing?

@wm75 sure

Would it be okay if I share the wf link privately and not in this thread? Is there a way to do that?

Yes, see my direct message :slight_smile:

Thanks a lot Wolfgang, I just sent you the wf link to your UniFreiburg email address!!

1 Like

This has to do with the size and complexity of your WF. We’ve found a relatively small (compared to your) WF, which has the same problem, and now have an issue for this: Large workflows are not rendering in workflow editor · Issue #15727 · galaxyproject/galaxy · GitHub, but fixing is not trivial.
To explain: the WF editor is a component that received a major rewrite in the new release, but nobody tested against WFs the size of yours (if you have a small WF or you create one, it should be opening in the editor just fine).

Thanks Wolfgang, any chance I could edit the wf in a legacy version of Galaxy (where the editing for this wf size used to work just fine)?

1 Like

Well, not easily because you’d need a server that has all tools in your WF installed:(
What you could try, if you feel confident enough, is to edit the downloaded WF file in a text editor and shrink it to a size that’s loadable, but admittedly far from ideal.
If it’s just a small modification that you want to do, doing this via a text editor might be feasible though.
If you only want to extend your current WF (not modify existing steps), you can also create a new WF and embed your existing one as a sub-WF into it (because it’s really just the editor not being able to show all the connection between steps, and a sub-WF will show as a single box).
Finally, but much(!) harder, you could set up your own small Galaxy 22.05 instance on a local computer, install necessary tools and edit the WF locally - kind of a last resort option.
Sorry that I don’t have any better solutions right now.