Can't configure network interface and admin users after local ansible Galaxy istallatation

Hello!
I used previously to install Galaxy via git. And was able easily configure its behavior via galaxy.yml. This time I have installed Galaxy via ansible following the official tutorial. It runs OK on 127.0.0.1:8080. But I can’t bind it to other interface (like 0.0.0.0:8080). And I can’t configure admin users. Also I had to run ‘ansible-playbook galaxy.yml --ask-become-pass’ instead ‘ansible-playbook galaxy.yml’
What am I doing wrong?

Hi @Eugene_Brenner

I’ve crossposted this over to our Admin chat at Matrix. They may reply here or there, and please feel free to join :slight_smile: You're invited to talk on Matrix

Hi @jennaj ,
Thank you! Have just joined talk on Matrix. Hope we’ll find solution :slight_smile:

For the admin users part: I add admin users (using the e-mail not the short name) in the “admin_users” comma-separated list field in “galaxy.yml”.

Maybe you need to register users before you can add them to that list?

Not sure about the rest.

1 Like

I tried to do so. Does not work either. By the way, there is no ‘galaxy.yml’ config right after Galaxy installation. I have to create it manually from ‘galaxy.yml.sample’ in /srv/galaxy/server/config where galaxy is deployed. Then restart Galaxy with logging into ‘galaxy’ user and running ‘galaxyctl restart’. But all settings in galaxy.yml are ignored. Also are ignored all other settings which I set in ‘/group_vars/galaxyservers.yml’ prior running ‘ansible-playbook galaxy.yml --ask-become-pass’, e.g. creating custom welcome page

Hi @Eugene_Brenner

Have you double checked all of the environment variables to make sure these are what you expect? I would suggest starting at the very top of this first guide: Hands-on: Galaxy Installation with Ansible / Galaxy Server administration

Hi @jennaj,
OK, I will do it. I could possibly miss something. This is my first experience with ansible. Will write here if or when I succeed.

I see, I manually installed my Galaxy (for now, temporarily), it seems the Ansible install is quite different.
I assume there necessarily is a galaxy.yml file that is being used, somewhere, which explains why the one you create manually is being ignored.
However the clean way to do it (without bypassing Ansible), seems to be by editing the galaxyservers.yml Ansible config file : Hands-on: Galaxy Installation with Ansible / Galaxy Server administration (link to the specific section)

1 Like

Hello, everybody,
I managed to configure Galaxy by manually editing config file /srv/galaxy/config/galaxy.yml. Somehow, ‘bind’ and ‘admin_users’ variables were not translated into it automatically during ansible installation. I understand, that it is not the best decision, but at least it works. Thanks to all, who helped :slight_smile:

P.S. I run Galaxy 23.2.1.dev0 on Debian 12

1 Like