converting saf to gtf, getting an error

Couldnt find a transcriptome gtf file, have a saf file and thought I would convert this, tried following the instructions here,

but I get an error on step 3

File “/cvmfs/”, line 107
exec code
SyntaxError: Missing parentheses in call to ‘exec’

was hoping someone could help

1 Like

Hi @a_d_i

The workflow you are referencing was created a while ago, and it has become outdated. Specifically, some of the tools included have updated versions.

You will need to edit the workflow to use the most current version of all tools.

An example of one outdated tool is in the error:

Original tool version included in the workflow:

  • Compute an expression on every row (Galaxy Version 1.1.0)

Updated tool version available in the Workflow editor (and Analyze Data/History view’s tool panel):

  • Compute an expression on every row (Galaxy Version 1.2.0)

I would suggest going through each tool, checking for updated versions, then replacing any outdated tools with the new version. Galaxy was recently upgraded to use Python 3, and several tools were updated from Python 2 to be compatible with the new environment. Given the unique nature of the upgrade, it wasn’t always possible to implement backward compatibility – many tools actually needed to be upgraded in workflows (the older versions will reliably fail).

Option 1: Update the Workflow itself directly


The original tool highlighted. Note the full tool name and version in the far right panel.

Tool added again to the workflow from the far-left tool panel, then highlighted. Note the updated tool name/version in the far right panel

From there, set the parameters for the new tool to match those in the old tool. Find others like it and do the same. Then reconnect the workflow “noodles”, starting from the input dataset through downstream tools, left to right, to incorporate the new tools. In the end, double-check all tool settings (compare old to new), then delete the old tools. If you make a mistake, you can always start over with a fresh workflow copy.

Reconnecting the noodles “left to right” is important. Metadata internal to any workflow’s logic requires that noodles are reconnected from inputs > tool1 > tool2 > etc when any changes are made. Not ideal, but currently necessary, for complicated technical reasons.

Option 2: Update the tools/processing in a History, and re-extract a Workflow

Run the workflow, find the first tool that errors in the history, replace it with the updated tool version, rerun, and repeat as needed. Once you have a successful processing path, delete the failed tools/runs, and re-extract a workflow from that history.

If you are not sure how to edit or extract a Workflow, several of the GTN tutorials include basic examples, including the Galaxy 101 and others under the topic “Introduction to Galaxy Analysis”.


Thank you so much Jenn!!!

I tried running the updated tool (it seems like there is only one component that needed to be updated), and then nothing happens. I must be doing something incredibly silly.