CVMFS twobit indexes for hg38 not downloaded as reference

This is a follow-up question to the topic I had asked last week here:

As per the guidelines by @jennaj in that topic, I started with a fresh install of Galaxy and enabled access to reference genomes and indexes via CVMFS. I can now access reference genomes and indexes for almost all tools except that twobit does not show the hg38 genome (for the tool “Translate BED transcripts”) in the dropdown options.
I looked at data tables and looked in to the twobit folder and I see hg19 only for human plus the number of options are also quite less (~47 entries). Is this related to the CVMFS cache size (set at 500)? Should I be seeing a lot more options in the twobit folder?

Thank you

Hi @prao123

The human hg38 is missing, along with several others. The hg19 duplicates were also cleared up in the hosted version. Legacy ticket. We’ll be addressing missing indexes over the next year.


  • use a translation tool not dependent on this index
  • use a Data Manager to add it directly for your server locally. Make sure to choose the hg38 dbkey when doing that.

Hello @jennaj
For pursuing the second option where I use the data manager to add the hg38 index, should I follow the order?

  1. Sam fasta index builder
  2. Picard fasta index builder
  3. 2bit index builder

Should I source the genome from UCSC?
I just want to confirm that it will not interfere with any of the indexes sourced from CVMFS? Are there any additional things I should keep in mind before I start the indexing?


Just run the extra 2bit indexer. Choose the existing hg38 database as the source.