Dataset error report using qiime2 feature-classifier (naive bayes)

Hello,
This is my first time using Galaxy, so I’d appreciate some help.
While trying to use the tool “qiime2 feature-classifier fit-classifier-naive-bayes”, the tool fails and feedbacks the following error:
"
Execution resulted in the following messages:

Fatal error: Exit code 127 ()

Galaxy job runner generated the following standard error:

/data/jwd05e/main/059/800/59800764/galaxy_59800764.sh: line 60: 3891.2 / 1: syntax error: invalid arithmetic operator (error token is “.2 / 1”)
"
I’ve tried googling it but couldn’t figure out what’s wrong. Can somebody help?

1 Like

Welcome, @Mariana_Lopes

As a quick guess: the tool is attempting to perform a mathematical function on data that is not a number. Or rather, not a number that it understands as a “valid” number.

This was probably a value in your input. Less likely would be some value computed by the tool. Why? I would expect the tool itself to calculate values it also knows how to interpret.

This is the line in the code referenced. It is performing a check, and that looks like it is screening for whole numbers. I could be wrong, so double check.

galaxy-tools/qiime2__feature_classifier__fit_classifier_naive_bayes.xml at main · qiime2/galaxy-tools · GitHub

How I found that line of code: Tool form → Options menu at the top right → See in ToolShed → the TS repository links out to Development repository → then clicked into the xml file.

This tool doesn’t have test data directly in Github, but the TS repository also has a link out to the Content homepage which is usually the original tool authors repository. For this tool, it is here GitHub - qiime2/q2-feature-classifier: QIIME 2 plugin supporting taxonomic classification, which points to https://qiime2.org/.

A screenshot there references a Galaxy designed for just this tool, packaged into a container → q2Galaxy - Galaxy Community Hub. But the EU server also hosts it.

At the top of that page, see the link to Learn more at the top → Data files: QIIME 2 artifactshttps://docs.qiime2.org/2023.2/concepts/#data-files-qiime-2-artifacts where the .qza “artifact” data is described conceptually, not literally, so not helpful yet…

Linked at the bottom there are TutorialsTutorials — QIIME 2 2023.2.0 documentation

Maybe compare to the tutorial methods and example data? This probably includes how you uploaded the data to Galaxy (if the .qza wasn’t created after Upload), then compare/retrace your steps to find out where/how the odd value was introduced, fix that, and try a rerun.

Hope that helps. If you think you found an actual bug (example: tutorial data also fails), please follow up by submitting a bug report directly from the red error dataset and post back here with a shared history link (see Galaxy Training!) and we’ll help with confirming/reporting the technical issue to the developers, plus maybe can come up with some workaround.

1 Like

Hello @jennaj,
Whilst waiting for an answer, I found this post on the QIIME 2 forum, which linked to this particular Galaxy server. I tried running the aforementioned tool with the same input and it ran and concluded successfully.
Regardless, thank you very much for your help and quick answer!

Great, thank you for posting this back!! The cancer.UseGalaxy.org server is run by a breakout US team associated with the UseGalaxy.org server. The EU team runs UseGalaxy.eu.

Each are attached to distinct compute resources. Everyone is welcome to have an account at any or all. How to copy data between servers directly (no intermediate download step) → Transfer entire histories from one Galaxy server to another

And, given that info, there is likely some configuration difference EU admins need to address. Or, maybe those two have a different version of the wrapper running. These servers get a LOT of bug reports from users, and sorting out which are actual server issues versus requests for general usage help is a big job (and why this forum exists :slight_smile: ). Maybe this ping will help @bjoern.gruening @wm75

1 Like

@jennaj @bjoern.gruening 3891.2 happens to be the amount of memory in Mbytes that standard tools get allocated on usegalaxy.eu since our switch to tpv earlier this month.
Apparently, qiime 2 can’t handle memory that’s not an integer in MBs?! A simpley workaround would be to give it a round number of memory.

1 Like

Hi,

this particular error has been fixed, but I think it is just hiding a real underlying error.
Please rerun the tool and please report any new error that you will get.

Thanks,
Bjoern

1 Like