Error in workflow maxbin2 step

HI!When I was running the workflow, I found that the maxbin2 step was wrong. What happened?

Hello @chenqiang

Have you reviewed the job logs? How to find those is in the banner at this forum, and also here → How to get faster help with your question

Screenshots of the entire job information page, with a very minimum of the input/parameter section (with the inputs expanded) plus all three full logs is probably important for this one. If the collection inputs do not expand or are nested, go into the history and expand one of the datasets, or both ends if a paired set. I’m curious about the exact datatype, database, and top of the file(s) in a peek view.

I can’t remember if you already stated the version of the local Galaxy (or public server URL?) or not in the other question, so please also clarify where you are working. The full tool name/version too please – captured from the job information page or top of the tool form. Not sure of those will matter or not but providing as much context as possible will lead to the quickest feedback.

Let’s start there, thanks! :slight_smile:

I checked that only an error occurred while running the tool _ bins/cat _ bins/5.2.3+galaxy 0 was displayed. There were not many details.

The following is the specific information of workflow:
Step 1: Input dataset collection
Collection of paired reads = Select at Runtime.

Step 2: Trim Galore!
Is this library paired- or single-end? = Paired Collection
Select a paired collection = Output ‘output’ from Step 1.
Adapter sequence to be trimmed = Automatic detection
Trims 1 bp off every read from its 3’ end. = False
Remove N bp from the 3’ end of read 1 = Not available.
Remove N bp from the 3’ end of read 2 = Not available.
Trim Galore! advanced settings = Full parameter list
Trim low-quality ends from reads in addition to adapter removal (Enter phred quality score threshold) = 20
Overlap with adapter sequence required to trim a sequence = 1
Maximum allowed error rate = 0.1
Discard reads that became shorter than length N = 20
Instructs Trim Galore! to remove N bp from the 5’ end of read 1 = Not available.
Instructs Trim Galore! to remove N bp from the 5’ end of read 2 (Only for paired-end reads) = Not available.
Generate a report file = True
specify if you would like to retain unpaired reads = Do not output unpaired reads
RRBS specific settings = Use defaults (no RRBS)

Step 3: FastQC
Short read data from your current history = Output ‘output’ from Step 1.
Contaminant list = Select at Runtime.
Adapter list = Select at Runtime.
Submodule and Limit specifing file = Select at Runtime.
Disable grouping of bases for reads >50bp = False
Lower limit on the length of the sequence to be shown in the report = Not available.
length of Kmer to look for = 7
Step 4: Unzip collection
Paired input to unzip = Output ‘trimmed_reads_paired_collection’ from Step 2.
Step 5: Flatten collection
Input Collection = Output ‘trimmed_reads_paired_collection’ from Step 2.
Join collection identifiers using = underscore ( _ )

Step 6: Collapse Collection
Collection of files to collapse into single dataset = Output ‘forward’ from Step 4.
Keep one header line = False
Append File name = False

Step 7: Collapse Collection
Collection of files to collapse into single dataset = Output ‘reverse’ from Step 4.
Keep one header line = False
Append File name = False

Step 8: metaSPAdes
Run only assembly? (without read error correction) = False
Automatically choose k-mer values = False
K-mers to use, separated by commas = 21,33,55
Library type = Paired-end
Orientation = → ← (fr)

  1. Files:
    Select file format = Separate input files
    Forward reads = Output ‘output’ from Step 6.
    Reverse reads = Output ‘output’ from Step 7.

Step 9: MaxBin2
Contig file = Output ‘out_contigs’ from Step 8.
Assembly type used to generate contig(s) = Assembly of sample(s) one by one (individual assembly)
Input type = Sequencing Reads
Reads file = Output ‘output’ from Step 5.
Output abundances = False
Reassembly = False
Advanced options:
minimum contig length = 1000
Maximum Expectation-Maximization algorithm iteration number = 50
Probability threshold for EM final classification = 0.5
Generate visualization of the marker gene presence numbers = False
Output marker gene presence for bins table = False
Output marker genes for each bin as fasta = False
Output log = False
Marker gene set = 107 marker genes present in >95% of bacteria

Step 10: CAT bins
metagenome assembled genomes (MAGs/bins) = Output ‘bins’ from Step 9.
CAT database (–database_folder,–taxonomy_folder) from = local cached database
Use a built-in CAT database = CAT_prepare_20190719
Use previous prodigal gene prediction and diamond alignment = No
range = 10
fraction = 0.5
Set advanced diamond options = No
CAT add_names for = classification.names.txt
Only output official level names. = False
Exclude bit-score support scores in the lineage. = False
CAT summarise report = No
= bin
= bins
= bin,
Select outputs = log Prodigal predicted_proteins.faa ORF2LCA.txt (taxonomic assignment per predicted ORF) bin2classification.txt (taxonomic assignment per metagenome assembly)

Hi @chenqiang

Click into the “i” in a circle icon, instead of the bug icon, and please post that content back instead.

Oh,take a look at it for me, thank you.

Hi @chenqiang

The last line of the Tool Standard Output suggests a data problem. That could be actual content conflicts, or some problem the tool had with reading in your specific data (format, labeling).

Did you try a search yet to see if there are any online discussions about it yet?

Or, have you compared your input data to the examples from the tool’s authors? See the bottom of the tool form for link outs.