Error uploading pub files

Hello, I want to commence molecular dynamics simulations but can’t successfully load my pub files. what do I do?

1 Like

Welcome @rowaiye

Where are you using Galaxy?

  • If at a public Galaxy server, please share the URL
  • If your own Galaxy, please share a bit about what type (local, cloud, docker) and where you sourced it.

Let’s start there, thanks!

Thank you
I am using this link:
Thank you

1 Like

Thanks @rowaiye for the extra info.

The data you are trying to retrieve may be protected because it contains personally identifiable information. You should never use a public Galaxy server when using that class of data. Instead, set up your own Galaxy server and keep it protected/offline. Example:

If your data is not in that class, it may be that you are attempting to upload data that is in a compressed archive that Galaxy does not recognize or is unable to parse. Unpack the archive and upload individual datasets instead.

The methods to Upload data into Galaxy are:


Advanced (in the topic “Data Manipulation”):


Thank you. I seem to be making progress. I have uploaded the pdb file successfully and commenced in the initial set up.
How long does this take? I see the files to be generated are still in red.

Thank you



A red dataset indicates that the has job errored.

Did you use “autodetect” for the datatype assignment when Uploading the data? If not, try that next.

And even if you did use that method already, try a rerun for the Upload anyway. There were some server issues at Galaxy EU last week. I believe that those are now resolved.

ping @bjoern.gruening

@rowaiye if your PDB file is not huge the upload should take minutes and it should turn green not red.

I just tried and it works fine for me.

I have been able to successfully upload on the platform but nothing is
working especially with the chemical toolbox

What does this mean? What are you trying to do?

@rowaiye have a look at this tutorial:

It should explain the steps for successfully setting up an MD simulation with GROMACS in Galaxy. If you have any problems please let us know.

A common reason that the setup tool might be failing is that you are not cleaning the protein of solvent and heteroatoms - e.g. the NAP ligand in your PDB file. This is also described in the tutorial I linked.

Good luck! :slight_smile:

1 Like

Thank you.
I have cleaned the protein of ligand and water molecules. I am still
having error messages in the initial set up for simulation. Could this
be because of missing atoms in the back bone?

1 Like

Hi @rowaiye,

I have tried out the setup tool with your structure and it seems to work: Perhaps the error you’re experiencing is due to the force field you selected.

That said the system you are trying to study will be pretty tough, especially if you are new to MD, and I suspect you will not be able to do every step in Galaxy. Just a word of warning. You may find it easier to separate the two protein chains and perform the setup separately. Let me know if you encounter any more issues and I’ll be happy to help, it will also help us to improve the Galaxy MD tools. :slight_smile:


1 Like

Thanks for your continued support. I am not able to do ramanchandran plot and other MD analysis after generating a trajectory file.
Please help

Hello, glad you got so far! :smiley:

Could you share a link to your history please? Otherwise it’s difficult to diagnose the problem.

Hello @rowaiye,
make sure you define the correct dihedral angles.

    For protein φ and ψ dihedral definitions see
    For glycan φ and ψ dihedral definitions see

Please share the histories if you failed to get the plot


Executed Ramachandran Plots and successfully added 1 job to the queue.

The tool uses 2 inputs:

Dr Adekunle Rowaiye (DVM, MSc, FAGAN, FCVSN)
Asst. Director,
Dept. of Medical Biotechnology,
National Biotechnology Development Agency
Abuja, Nigeria.

The Academic Staff Union of Research Institutions (ASURI), NABDA Branch

Thanks for reporting this error, we will try and fix it as soon as possible.

In the meantime, I suggest you use the previous version of the tool to perform the analysis. You can access this by clicking on ‘Versions’ at the top of the central panel. However, the earlier version of the tool requires file upload in PDB and DCD format, so you will have to perform this conversion first using the MDTraj tool.

I hope this helps.


Thanks for your response. I cant find
‘Versions’ at the top of the central panel. All I can see is News and Events

Please see the top right in this image:

ok. thanks