FTP upload problem

Hi, I have a problem when I am uploading a big file (22 GB) using FileZilla.
Everything starts ok, but at some moment the connection down. I have a 100MB connection, and the system gives me a message as"remaining 4 or 5 hours". Any idea?

1 Like

Hi @Mariano_Pardo

Filezilla has an option to “resume transfer”, have you tried that?

Galaxy FTP FAQ: https://galaxyproject.org/ftp-upload/

Filezilla help: https://filezilla-project.org/client_features.php

1 Like

Thanks Jennaj
I tried but did not work. I will try with an FTP “Keep-alive” option active because I discovered that my connection always down at 2 hours.

1 Like

True, resume won’t always work if too much time passes between the network connection drop and the “resume”.

Can’t harm to try the other option. I would also suggest checking in on the upload periodically, so you can resume right away (the server itself may drop connections). I’ve had to do this myself when working over a slower connection/large data.

If you need more help, please share a few more details with your reply post.

  1. Are you loading data to a public Galaxy server? If yes, what is the base URL? We can help you to find the admins.
  2. If some private Galaxy – the next step would be contacting those admins directly and explaining the problem.

Each server is independently administered/configured. There may be server-side connection limits.

Your IP provider might also have data or time limits for transfers/connections. For that situation, contacting them to find out what can be done (if anything) would be the way forward.

Let us know how this works out, will help others :slight_smile:

Hi Jennaj,
Mariano again… Sorry by bothering you. I uploaded a fasta.zin file without any problem. These file coming from an illumina paired genome sequencing, but could not be processed by galaxy. There exist some unzip tool? Could be possible to unzip these files inside of galaxy once were uploaded?
best regards

I am not sure what format fasta.zin has, but Galaxy understands certain compressed formats and will keep them compressed on upload (to preserve your quota) and decompress on the fly when running tools. You can bypass this behaviour by selecting the uncompressed datatype when uploading (.eg. fasta(

Sorry, my bad. “fasta.zip” should have written.
I was trying to upload uncompressed files, but these are so big that the process always cut.
Thanks for your help.

1 Like

With good network there is no technical limit on how big of a dataset you can upload to modern Galaxies.

What I meant by this is to still upload the compressed datatype but in the upload dialogue select fasta as the datatype, Galaxy will uncompress it on the server side,

1 Like

Small warnings to add to @marten’s reply:

  1. Galaxy only loads the first dataset in a zip archive. Unpack the archive and load individuals files if the archive contains more than one dataset.
  2. If your connection is slower, try using FTP Upload. Interrupted transfers can be resumed. FAQ: Loading Data

Hi Jennaj and Marten,
good news!
Finally, my files were uploaded. I activated the option “keep-alive” in Filezilla and it worked perfectly.

Thanks so much

1 Like