Galaxy no longer allows viewing bigwig files in UCSC genome browser

Hello, for several years I have been using Galaxy to host my bigwig files, which I then visualize in the UCSC genome browser. Just recently, I have found that Galaxy doesn’t allow this feature anymore. To elaborate: Typically, I would upload my bigwig file to Galaxy, and then I could simply click the bigwig file in my history to open a small box which displayed an option that said (maybe with different wording) “view in UCSC.” Clicking this option would immediately take me to the UCSC genome browser, with my bigwig file being displayed as browser tracks. This was great, and was exactly what I wanted. But in recent weeks, this option to “view in UCSC” has disappeared from my bigwig files being hosted on Galaxy. There is no longer a clickable link that says “view in UCSC.” Could you help me understand what is going on? Is this feature totally gone from Galaxy? As in, do I need to find another host for bigwig files which I want to view in the UCSC genome browser? Or is this feature still available in Galaxy, but just re-worked in a way that I haven’t realized? To try an alternative approach, I clicked the “copy link” icon for my bigwig on Galaxy, and tried pasting that link when I manually upload a custom track to the UCSC genome browser, but this approach is also not working (it prompts an error from UCSC saying that they could not open the file being specified by the link which I copied from Galaxy for my particular bigwig). It seems strange that Galaxy would still be okay with hosting our files, but not be okay with making those files (a bigwig file, in my case) viewable/accessible to other sites like the UCSC genome browser.

Hello!

Yep, you guessed it – it’s still in Galaxy but accessed a different way. We’ve consolidated all the visualization options to a single interface, and if you click on the visualization icon for the dataset in question:

image

And then in the middle panel at the top, this should be what you’re looking for:

Let me know if this isn’t working correctly for you and I can dig deeper. Thanks!

3 Likes

Thanks! That’s exactly what I was looking for.