How to import a Dataset 'from User Directory'

Hi,

I’m trying to import a Dataset from User History
In the Datasets dropdown list, from History item is visible but from User History does not show up for a non-admin user.
For an admin of the Galaxy instance, from User History is present.
There is no error in the galaxy log.

In galaxy.yml, the library_import_dir and user_library_import_dir have been configured (they point to the same directory).
A subdirectory has been manually created under user_library_import_dir for the non-admin user with rwx permissions.

I’ve noticed that in $GALAXY_ROOT/client/src/components/LibraryFolder/TopToolbar/FolderTopBar.vue
user_library_import_dir is set to false (function data()). Is this related to my problem?

Thanks a lot,
Jin

1 Like

Hi @Jin

With default settings, a general user with non-admin status has access to:

  1. Their own datasets (including any they imported from others in a fully shared state)
  2. And, any datasets in a global shared state (Data Library).

Only admins have access to other classes of data.

For this option, I’m not sure if it will do what you want by itself. But, you could try setting it to true, restart, and see what happens. Then review the other similar options to fine-tune. Each is described here: Configuration Options — Galaxy Project 21.09.1.dev0 documentation

@jennaj
Thanks a lot.

I’ve modified the FolderTopBar.vue file (with a field name change to check) and restarted Galaxy but nothing has changed.
Is there any kind if ‘compilation’ to do? (sorry for the question, I’m a Vue newbie)

Best,
Jin

Actually this is a bug in v20.09 which is described in https://github.com/galaxyproject/galaxy/issues/10982
and fixed in later commits.

1 Like