how to increase data quota on local galaxy

I am the admin of local galaxy installation. Files more than 2GB fail to upload and run.
How to upload data from a local disk directly so that I can continue with my work.

1 Like

I believe you can’t (but some one need to confirm), and I am assuming that you are not using a recent galaxy version. I think out of my head the 2GB limit was gone after version 18.05.

My quick fix at the time was to enable FTP ftp_upload_dir: '' in this FTP folder you can create a folder with your email as the name for that folder. And then upload it manually.

I am using the recent version galaxy 19.05.

Maybe settings in nginx or apache if you are using that. Do you get an error?

The 2GB browser upload soft limit is long gone, it was more of a browser’s issue than Galaxy’s. If you already have data local to Galaxy instance the best way is to not upload them, just to import them with Data Libraries using links instead of copying. This is how:

1 Like

Thanks…shall try it and let you know.