incorrect link to bam download

The download links for bam output files (13G) from MarkDuplicate and AddOrReplaceReadGroups are downloading only few Mbs of html file rather bam. I tried using “wget”, “curl” both and also tried to transfer these files to server but it failed.
Please tell me how to download appropriate files or what is the problem with copy link option.


how do you copy the download link for bam file? BAM datasets in Galaxy have links to both BAM alignment and index file. To get link to BAM alignment, click on Save icon for BAM dataset (left mouse click). You’ll see two links, Download dataset and Download index. Copy link to the dataset using rigt mouse click > Copy URL.
Hope this helps.
Kind regards,

I did the exactly same as you explained. The downloaded file is of 6317b only, however the file size on details section shows 13GB. I don’t understand what’s wrong here.
Need help!


Hi guptapa,
I reproduced the download using link issue with Galaxy Europe. I cannot copy a file using URL from Galaxy Europe to Galaxy Australia but have no issue with download of the file to a local computer.
No problem with copying data using URL from Galaxy Australia to Galaxy Europe.
Kind regards,

Hi igor,
I’m sharing the screenshot to show from where I’m coping the downloadable link and link as well. Could you please share the link which allowed you to download correct file?
I used wget with --no-check-certificate to download the file.
Download dataset

Can I transfer the data from Galaxy Europe to USA ( with correct download link?


Hi Guptapa,

I can download (small test) files from Galaxy Europe by clicking on Save icon (left mouse click). I have not tried a big file.

Download from Galaxy Europe using URL does not work for me. I used a link for a file on Galaxy Europe. I hope admins of Galaxy Europe can comment on it, but it seems the issue is withing Galaxy Europe: I can copy files from Galaxy Australia to Galaxy Europe using a link from Galaxy Australia.

Kind regards,


Hi @guptapa and @igor

Good detective work. The how-to is a bit different at EU. Maybe someone already discovered how this works, but in case not: is set up to have all data private and not publically accessible by URL. If you are trying to move data between servers, the accounts are distinct, so the sharing state needs to be set at EU to be more permissive to transfer data by URL to anywhere else (other Galaxy servers, external cloud storage, etc).

Try this:

  1. Go to the history that contains the dataset
  2. Pull down the history :gear: menu and click into Share or Publish.
  3. Set the first option to share the history by link, and make sure that the dataset you want to share is included. You don’t need to publish.
  4. Go back to your history with the dataset
  5. Then copy/paste the dataset link other places (other Galaxy servers Upload tool).
  6. Unshare the history or leave it in a shared state.

Adjusting privacy settings for your account:

Accounts at any of the UseGalaxy.* servers have the options to adjust the default sharing status for what is most convenient for you. It would be very unlikely for anyone to guess what a random link is, let alone understand what that data represents, but any access at all has to be an explicit opt-in at the EU server for GDPR reasons.

To see how it works – try doing the reverse between the ORG server to the EU server without any changes. The data will transfer unless you set up the account preferences to be different from the default.

Another way to see how it works is to toggle the first of these two global settings at EU in User > Preferences, create a new history, add a new dataset, and what happens when transferring that dataset by URL. Data created before the toggle will not be impacted, data created after will be.
The second setting makes more permanent changes to all current data (everything has the state changed to private) but know that this cannot be undone with one change. Instead, you’d need to directly reshare any histories (and the datasets contained) / workflows / etc that were previously shared if that matters to you.

Set Dataset Permissions for New Histories

Grant others default access to newly created histories. Changes made here will only affect histories created after these settings have been stored.


Make All Data Private

Click here to make all data private.

Downloading to a local desktop from the :floppy_disk: works at EU with any sharing state since when you are logged into your own account, your account is assumed to be private and only directly accessible by you, and only while logged in. I’m not sure if the API key is needed for wget at the EU server. The EU team can advise, or someone can test that out and post back what works and doesn’t at the different servers. We could make an FAQ to capture the information in one place, and attribute your account here, or better, your github account.

The March 24th webinar here has more details. We went over the account preferences options then ran through a collaborate-by-sharing demonstration: Galaxy-ELIXIR webinars series: Advanced Features | ELIXIR.

Hope that helps!

Just to confirm that data transfer nby URL from Galaxy Europe works on a history shared by link.
Super handy!
Thank you!

1 Like

Hi jennaj,
Thanks for the info. Looks like its working.


1 Like