Downloading datasets using command line NOT WORKING

Hi guys,

I went through this training and tried to download the BAM file to another server (not galaxy, but my Univerity HPC cluster) using command lines listed and none of the options are working. wget and curl are installed.

Resolving (
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 403 Forbidden
2023-04-26 12:13:06 ERROR 403: Forbidden.

I went through these suggestions as well and I realized that for some reason I don’t have a permission because I dont see a Premission tab for my BAM files (Dataset > Pencil icon > Edit attributes > Permissions). Why is that so? Interestingly, I am able to download it locally on my computer but it takes a huge amount of time and then I have to transfer it to our HPC server.

Finally, to confirm that this is due to a permission issue I tried to download an individual result file (fasta statistics,tabular) for which I see that I have permission (at least I see a permission tab). But, I am getting the same error.

Note: the e-mail address that I use to log in to Galaxy (and that is listed in premissions) is not the same that I use to log in to my cluster (for the former I have to use my academic address). Just mentioning, no clue if that’s important.

Can anyone help me please and save me a huge amount of time?

I don’t have a complete answer for you, but this is most certainly a permissions problem with your datasets in Galaxy.

Your email address and the fact that you can download the data through Galaxy’s interface at least have nothing to do with the issue. (The download through the UI will always work because you are logged in.)

However, when you’re saying that your email address is listed in permissions, then this could be your issue. Make sure that it’s listed only under manage permissions, but not under access.
access needs to be completely empty for anonymous downloads from the command line to work.

As to why one of your datasets doesn’t have a Permissions tab: this usually means that you’re not the owner of the data. Is this a history that originally got shared with you by somebody else, or did you generate the dataset through an analysis?

1 Like

Thank you for your reply and explanations. :slight_smile:

To answer your question - I generated the dataset in question through an analysis on my own. It is not shared with me. it is a list with 4 bam datasets so I have a download button to download it on my own computer (the whole dataset, takes way too long) but, no option to access the link button for wget. I only have links for individual bam results and for those I see no permission tab and I am getting the ERROR 403:Forbidden.

Update: I followed your suggestion for removing my e-mail from the access list (for an individual result file for which I have a permission tab) and it worked for downloading from the command line! tnx!

So I guess, I have to figure out why my bams seem not to have permission since the command line is obviously working.

it is a list with 4 bam datasets

Aha, so that is important to know. The current version of Galaxy, unfortunately, does not display an edit button (pencil icon) for elements of a collection. The collection itself has one, but collections don’t have permissions associated with them.

One workaround until Galaxy receives an update is this:

  • go inside your collection to reveal the 4 bam elements
  • click the eye icon on the first dataset
  • you’ll see a preview of the dataset and the link in your browser’s address bar will read something like:
  • replace the preview in that address with edit and hit Enter on your keyboard, and you’ll be taken to the page with that dataset’s Permissions tab
  • make your changes and repeat all steps for each of the other three elements

hi! it all makes sense now! while you were typing your last reply I figured out an additional way how I can do this: I can access individual bam files through “show hidden” option (i always forget about that one!), and then I see a permission tab for each individual bam, I changed the access option and managed to download through a command line. nice and easy. I’ll just make sure next time I make a history I have this access option off and that’s it. thank you so much! I tried your way but nothing is happening when I press enter, maybe it’s something with the Galaxy server, I believe this way will work too. thank you so much! :slight_smile:

1 Like

Perfect! Glad it works now.

Was thinking about the unhiding option, too, but didn’t know how large your history is (can be a real pain with large ones and the datasets of interest somewhere in the middle), but, yes, good to remember that the option exists :slight_smile:

Dear Lada could you please explain me how I can download a dataset into Galaxy…the URL link doen’t work…thanks

Dear Anna ,

Do you want to download it on another cluster or a local PC? Did you try anything from what was suggested above? what is the error that you get? did you check that your e-mail from the access list is removed (in case you want to download it on another cluster)?

1 Like