Issue with Krona pie chart tool

admin
tool-install
gui
whitelist
display

#1

I am working on a metagenomics project and trying to use Krona pie chart tool to visualize my data. In recent runs, it stopped generating the chart. Instead, it began to display hypertext coding for the HTML. Is there another tool for generating a pie chart or do I need to change formatting the data (I run data generated after running Convert Kraken tool). Please let me know.


#2

I suspect administrator of your Galaxy updated the tool but did not add the updated version to the whitelist, so the resulting html is getting sanitized for security reasons and you see it mangled.


#3

I think that may be the issue. Tool selections indicate that some of Kraken tools have been updated, and I started having issue with Krona after the “updated” signs began to appear. I am not sure what I can do, however.


#4

You need to contact your administrator. Which Galaxy are you using?


#5

The problem solved! I needed to pick the most recent version of Krona to run the data. It was helpful to have someone identify the problem and lead me to the solution. Thank you so much.


#6

Hello. I have the same problem with Krona Pie Chart. What did you do to solve it? Thank you.


#7

The prior user needed to switch to using the most current version of the tool: Krona pie chart from taxonomic profile (Galaxy Version 2.6.1.1). This is the version loaded from the tool panel at the public Galaxy Main server at https://usegalaxy.org. The source is: https://toolshed.g2.bx.psu.edu/repository?repository_id=039c93c1e3ed387f

If that doesn’t help, a few questions to help clarify the issue so we can offer help.

  • Where are you using Galaxy? URL of the server would help (if public).

  • If this happened in your own local Galaxy, what version of Galaxy and what version the tool are you running? Has it worked before or was this the first time running it? Do other tools execute correctly?

  • How does the problem with the Krona Pie Chart tool manifest? With a failed error job (red dataset) or successful but unexpected results (green dataset)?


#8

Hi. I am using galaxy at https://usegalaxy.org/
All tools are executed correctly, except Krona Pie Chart. The results appear in green but it says “tput: No value for $ TERM and no -T specified”. When I try to visualize the results with the eye button, an html code appears. If I click on the “Visualize this data” button, the tool remains indefinitely thinking “Galaxy is launching a container in with to run this interactived environmnent”.


#9

Thanks for the extra information and reporting the problem. Reviewing now, more feedback once done.


#10

Ok, I was able to confirm the display problem. (The “term” warnings can be ignored). An open ticket has been created to fix this tool and another recently updated: https://github.com/galaxyproject/usegalaxy-playbook/issues/203

In short, use the prior version of the tool: Krona version 2.6.1. Switch versions using the “Versions” menu at the top of the tool form.

Thanks for reporting the problem!