Limma tool error "line 2 did not have N elements"

Hello,

I am using Galaxy to conduct a gene expression meta-analysis using data from GEO. Unfortunately, while conducting a limma analysis, I keep getting the following error for a lot of the datasets

Fatal error: Exit code 1 ()
*Error in scan(file = file, what = what, sep = sep, quote = quote, dec = dec, : *

  • line 2 did not have 4 elements*
    Calls: read.table -> scan

I have also tried downloading .CEL files from GEO and then QCnormalization or downloading series matrix file and then using ‘import custom data’ option but each time, the limma analysis terminates at the same error.

Any advise would be really appreciated.

Thanks!

1 Like

Hi @priya_rai!

I’m wondering if the headers in your data are not being parsed correctly (similar to this issues with another tool).

Extra spaces/tabs could also be a problem, anywhere in the file but likely in the first row. So check for those and fix. Tools in the Text Manipulation and the Select tool can help to clean up tabular data.

If needed, you can reformat the headers so that each data column has its label all as “oneword” – no internal spaces. Dashes might be ok, too, so that would be a column label formatted something like this “one-word-and-maybe-more”. Avoid starting any labels with a number, dash, or any other non-alphabetic character to avoid problems.

If you can’t figure out the issue, where are you working? Public Galaxy server (which URL) or someplace private?

If public, you could share the history with me (generate a link, making sure to check the box to also share the datasets) and send it back in a direct message. Or share it publically in this thread if you are Ok with that. If working at Galaxy Main https://usegalaxy.org, just send this in as a bug report from one of the error datasets and put a link to this post in the comments so we can associate the two).

Looking at the data in plain text here probably wouldn’t be enough. Especially if it ends up that we should consider having the tool handle data like yours better in the future. These wrappers are still somewhat new. Usage improvements will evolve over time, from feedback like yours :slight_smile:

Hi Jennifer,

Thank you so much for replying!

My history is accessible through this link (http://localhost:8080/u/priyarai/h/unnamed-history-1)

I have tried formatting the series matrix file (step 496) but I still get the same error.

I would be obliged if you could have a look!

Thanks in advance,

Priya

1 Like

hi @priya_rai

That link is to a private server, not a public one, so I cannot review there.

Please try to see if you can reproduce this on a public server.

UseGalaxy* choices

Each has a larger account quota size than many other Public Galaxy sites plus I’m an admin at Galaxy Main which can help with troubleshooting sometimes. But any of these would work.