local machine can't use reference genome

Hi team,

I try many times, but I don’t know how to use online reference genome.
When I use bwa-mem.

If use own upload fasta.
bwa-mem will index fasta every time.

Could you told me how to fix it.
Very thank you,

1 Like

I am not 100% sure so do some extra research yourself. But possibly you need this: https://toolshed.g2.bx.psu.edu/repository?repository_id=d4b644c94642cd8c?

You can install it from your own toolshed page.

1 Like

Hi gbbio,

When I install data_manager_bwa_mem_index_builder.

Than results was same.

Source FASTA Sequence can’t find fasta file.

Do you know what problem is ?
And bwa-mem have same problem.
The bwa-mem can’t read fasta file (no matter I was upload fai, bwt, amb,ann, pac, sa file or not).

I am looking forward to your reply.

1 Like

Ah, I think I figured it out =) I got it working by installing data_manager_all_fasta_path first:

After installing you have a new data manager and trough this one you can add your fasta file. I only filled in the path field for the entry field.


Can a developer now tell me how to remove the files again? =)


Also see:


Thank you,
It’s work !!!

Could I ask other quation ?
In the local galaxy.
How to set threads when I use bwa-mem.
The command line only display “GALAXY_SLOTS”.
However I don’t know which config can set “GALAXY_SLOTS”
The machine have 32 vCPU but galaxy only can use one vCPU.

I am looking forward to your reply.

1 Like

The variable $GALAXY_SLOTS contains a value coming from the galaxy/config/job_conf.xml file. Here you can set the number of threads.

More info:


1 Like

Dear gbbio,

Thank you your reply, but I can not found job_conf.xml in config folder.
It’s mean must change file name from job_conf.xml.sample_advanced to job_conf.xml ?
Then, rerun Galaxy ?

I can’t thank you enough.

Oh, yes you to need or can change on of the examples to job_conf. Think job_conf.xml.sample_basic is easier.

Thanks gbbio,

Do you know how to set mutlithreads when we use bwa-mem.
Or job_conf.xml example.
Because tutorial doesn’t have.

Think you need to rephrase your question because I don’t think I understand what you mean. But:

Do you know how to set mutlithreads when we use bwa-mem.

This can be done by setting workers to 32 in the job_conf. If you set this to 32 the variable $GALAXY_SLOTS gets this value.

Or maybe you can adjust the xml file yourself but I dont know if that is recommended. I dont see the harm in that but not sure. The xml file you find here I think galaxy/database/shed_tools/toolshed.g2.bx.psu.edu/repos/devteam/bwa/somecode/bwa your path does not have to be exactly the same.

1 Like