Problem on Picrust2 webtool, even with tutorial files.

Hello,
I tried to use the webtool Picrust2, however even by using the tutorial fasta and biom files available at this adress
(http://kronos.pharmacology.dal.ca/public_files/picrust/picrust2_tutorial_files/chemerin_16S.zip ) it is not working.

I go in “Picrust2 full pipeline”.
Then I add the fasta file for the sequence placement options. (autodetected fasta)
Then in metagenome prediction options i add the biom file (autodetected biom2)

I then run tool. And obtain 4 red files with ‘a list of 0 lists’ message.

I will greatly appreciate help, as I don’t want to install QIIME2 (looks hard to me)

Thanks, Adrien. :slight_smile:

Here’s the error : * { “code_desc”: “”, “desc”: “Fatal error: Exit code 127 ()”, “error_level”: 3, “exit_code”: 127, “type”: “exit_code” }

The same error occured while using the option “generate tours” that gave me fasta and biom files that should work.

Hi @Mad.rien

I started up some tests when you first asked, and those failed as well, even with test data. I’m wondering if this is a legacy tool that is not supported anymore. I did just ask the EU team for more feedback.

What else I’ve found:

  1. The tool is no longer hosted at http://galaxy.biobakery.org/
  2. The tool remains at just one of the primary public Galaxy servers → UseGalaxy.eu. This is where my tests failed and where your job failed if this question was sorted into the correct category…
  3. Sparse error logs. No test cases in the tool wrapper.
  4. The authors host a google group here but are not sure of the status of the tool wrapper at public Galaxy sites: https://groups.google.com/g/picrust-users/c/IcJEftJPqGo/m/ZxALPQ5yAQAJ

Let’s see what the EU team thinks. ping @bjoern.gruening @wm75

1 Like