problems with the heatmap display

hi, I’m trying to do a heatmap in galaxy using the normalized data that I previously filtered with a p-adj >0.05, for that, I’m using the heatmap2 tool but when I visualize the heat map the samples with treatment are on the left and the controls are on the right, how can I fix this, so that the controls are on the left and the treatments are on the right.
For references the configuration that was used is:

  • Data transformation: plot data as it is
  • Enable data clustering: yes
  • Clustering columns and rows: cluster rows and columns
  • Distance method: euclidean
  • Clustering method: complete
  • Labeling columns and rows: label columns and not rows
  • Coloring groups: blue to white to red
  • Data scaling: scale my data by row

For context, I’m trying to visualize how the samples behave in general by condition (the columns are the different conditions (3 with treatment and 3 controls) and the rows are the genes)

1 Like

Hi @kizzy

You might just need to rearrange the columns in the input file.

This tool can do that: Cut columns from a table (Galaxy Version 1.0.2)

Avoid the Advanced Cut tool for this operation – it won’t rearrange the columns, only extracts.