Repeated "empty input datasets" error message


I have been attempting to use the Mothur pipeline to conduct my 16S community analysis. I was onto the beta-diversity step, using the Dist.shared tool. However, when running this tool I received the following error message, “Fatal error: Exit code 139 (), The tool was executed with one or more empty input datasets. This frequently results in tool errors due to problematic input choices.”

I was unable to locate the empty dataset in any of my input datasets or any of the datasets used in the proceeding tools that may have caused the issue. After attempting to re-run the tool a number of times to no avail, I attempted to conduct my entire analysis again.

However this time, when running summary.seqs tool after the sequence alignment step was completed using the align.seqs tool, this gave the same error. I assumed something went wrong in the align.seqs tool so I reattempted to run this again with the same data set but then this gave me the same error message again even thought I successfully ran the align.seqs tool with the same dataset that worked a few hours earlier.

Unsure why this is happening as I have successfully used Mothur in the past with no issues, any help would be fantastic, Ryan

Hi @RyanNThompson

This message usually means that one of the inputs is empty (possibly has only headers and no data lines) or sometimes that the one or more input datasets was entered more than once on the tool form.

If you still need help, you can post back a share link to your history publicly as a reply, and we can try to help. If you’d rather share the link privately instead, please confirm the URL of the public server where you are working (actually and state that you’d like a moderator to start up a direct message to post the history share link in.


Tutorial reference training-material/search?query=mothur

Let’s start there! Thanks

Hi Jennaj,

I thought that may be the issue so I looked through my datasets and could not find any missing entries. I also thought it could be due to a formatting issue as some of my samples have names of differing lengths. So when re-doing my analysis I renamed them names consisting of the same number of characters, but this did not seem to solve the issue.
A quick look over my history by a moderator would be fantastic, I am hoping to publish this data so if this could be done privately that would be great. The URL of the server I am using is

Thanks, Ryan