Unable to activate Google OIDC login

I am executing the Docker version of Galaxy and trying to enable the Google login. I have taken the necessary steps from Google’s side. However, I am not able to have the login button displayed in my instance.

This is an extract of my galaxy.xml, and I have configured the other two XML files as described in the documentation:

  enable_oidc: true
  oidc_config_file: config/oidc_config.xml
  oidc_backends_config_file: config/oidc_backends_config.xml

I have already activated the advance logging and yet I can’t see any related error in /home/galaxy/logs/*.log

Similarly, I cannot see any indication of Galaxy using OIDC or trying to reach Google.

Where can I find this sort of debug messages or how can I further investigate this issue?

1 Like

Hi @Diana

Please share more details about your Galaxy Docker server:

  1. Is it hosted publically? How? If not, that is probably the next step.
  2. What is the version?
  3. What other advanced configurations have you implemented?

Others with more Docker admin experience can offer more help, but this information will help them.

I’m also going to cross-post this to the galaxy docker chat. The maintainers may reply here or there, and feel free to join the chat: bgruening/docker-galaxy-stable - Gitter

Thanks for your answer.

  1. At the moment I am testing it locally, and if it is successful I might need to publish it.
    2) Docker version 20.10.14, build a224086
    And I have been testing bgruening/galaxy-stable:19.05 and bgruening/galaxy-stable:latest
  2. Nothing else. I just ran the Docker image, set up the Google details and then try to implement the OIDC option