unable to log into local galaxy

Hi there,

I was using galaxy earlier (was able to log on and install tools) but when I was uploading data from my computer to the local galaxy (link copy) I got an error message and it logged me out of galaxy. When I tried to log back into galaxy, I am unable to, the web log page does not respond and then times out. I have tried clearing my history and deleted stored passwords to galaxy but I am still unable to log in.

The last line in my terminal is:
galaxy.webapps.galaxy.controllers.user DEBUG 2020-04-21 15:04:28,746 [p:8320,w:1,m:0] [uWSGIWorker1Core3] trans.app.config.auth_config_file: /Volumes/My_Book/20.01/galaxy/config/auth_conf.xml

I have no idea how to resolve this. Any help would be hugely appreciated.

additional when run sh run.sh, I am not given a http link to galaxy but was able to access the web browser page because I had the address copy and available to paste from earlier.

additional details:
Using Mac OS Catalina, galaxy 20.01(new clone re-installed yesterday)

Hi @Lauren

Odd. As a first pass solution to try, check to see if Galaxy is running in multiple processes, and shut all down. Then start things up again and see if that resolves the problems. Let us know how that works out and we can troubleshoot more as needed.

FAQ: https://galaxyproject.org/admin/get-galaxy/#shutting-down-galaxy


Also, if you are loading local data up to your local Galaxy (on the same computer), is there a specific reason why you are using URL Upload? The URL would need to be in a publically accessible location for that to work, and there are alternative ways to load data. Or, maybe I am misinterpreting what you mean by “(link copy)”?

Local file browsing is one method to Upload data but is slow. Loading the data directly into a Data Library is much faster, if you are an admin, and avoids routing data through a web browser unnecessarily.

FAQ: https://galaxyproject.org/data-libraries/

Why using Data Libraries can be a good choice:

  1. Data does not consume more storage space when it is just an exact dataset copied from a Data Library into a History (for everyone who has access/permission to that Library).
  2. The same is true for datasets copied from one History to another History (but only when both Histories are associated with the same account).
  3. If you are the only user of your own Galaxy server and only use one account, the above won’t matter, but it seemed worth mentioning.
  4. And … sometimes it is convenient to use a script to move data into Galaxy. This is commonly from a location where data is routinely stored, or set up as a dedicated location to write production outputs (example: sequencing runs). That script could be run at regular intervals, to off-load running routine admin tasks e.g. set it up to run/load data whenever “new data” is available.
  5. Data Libraries, created by any method, can have permissions set up to control access (if or when needed… and again, is a feature more relevant for multi-user Galaxy servers).

thanks for getting back to me @jennaj

I have tried those suggestions fg, the response was no jobs running and the command jobs brought up no response in the terminal.

Sorry I wasn’t clear, I do add data through the data library system, and I tick the option of link copy the files.

What I have also noticed is, the original galaxy.yml file seems to go funny after making a copy of it. So when I first download galaxy, I make a duplication of the galaxy.yml.sample file, I edit the copy with text editor but it does not let me change the name, so I then save a copy to make desktop, make me an admin rename to create galaxy.yml and drag that to the config folder. but when trying to open the original galaxy.yml.sample file (which I have not opened at all before only duplicated and opened the copy) it says "operation can’t be completed because the original item “galaxy.yml.sample” can not be found.

Could this have something to do with it? Although I’ve had galaxy up and running after making me as an admin, but it won’t let me log into galaxy now.

Update: I have now been able to log into galaxy, this was resolved by clearing my web browser history again. I’m not sure why this had an effect.

But I am now getting errors through the galaxy web interface and the terminal when trying to run a tool. When I tried to go into admin to go to the error log, It had logged me out so was unable to access the admin tab and then went I try to log back in, I get the same problem again of not being able to log in. The web browser is unresponsive and the last line in the terminal is the same as before:

galaxy.webapps.galaxy.controllers.user DEBUG 2020-04-22 10:35:36,368 [p:877,w:1,m:0] [uWSGIWorker1Core1] trans.app.config.auth_config_file: /Volumes/My_Book/20.01/galaxy/config/auth_conf.xml

1 Like

@Lauren

You might want to start over with a fresh checkout.

  1. Start Galaxy up the first time, without making any changes. Then shut it down and make administrative adjustments as needed.
  2. Note that the galaxy.yml.sample file does not really exist under the /your-galaxy-path/config directory directly anymore, that is now just a symbolic link to where the file actually resides: /your-galaxy-path/lib/galaxy/config/sample/galaxy.yml.sample

Compare and you’ll see the symlink, either at Github or in your own galaxy directory.

Symlink for galaxy.yml.sample is in here: https://github.com/galaxyproject/galaxy/tree/release_20.01/config

versus

Where that galaxy.yml.sample symlink points to: https://github.com/galaxyproject/galaxy/blob/release_20.01/lib/galaxy/config/sample/galaxy.yml.sample

Give that a try and see if it resolves the problems. We can troubleshoot more from there.

Are you using python 3.7? This is a bug I have a fix for in https://github.com/galaxyproject/galaxy/pull/9642. You can pull that manually if you’d like, or, in the interim downgrade to python 3.6, and you should be good to go. Technically, we only support 3.5 and 3.6, but this code will fix login issues with 3.7.

2 Likes

thank you so much @dannon So if I go to the get galaxy page and update, that will provide me with the de-bugged version? will this wipe any data I have in my galaxy at the moment?

Dear Dannon,

Thanks for posting a fix for this issue in Python 3.7.x. I clicked on the link you posted, but since I am not an usual Github user I have no idea how to proceed. I understand you made changes to the passwords.py file, but I cannot download the new version of this file. Should I copy and paste the code I find in the “Files changed” tab in your link thus altering my local passwords.py local file?

Cheers!

Dear Dannon,

I altered my local passwords.py file as per the modifications indicated in the “Files changed” tab and my login worked again!!! Thanks a lot, mate!

1 Like