galaxy 19.01 start-up hanged after local installation

after installing galaxy locally using git when i execute the script it’s hanged after showing the server address localhost:8080 when i try to call server address localhost:8080 through browser it’s showing a blank page. I have galaxy 18.0 in the same system its working fine.please help

1 Like

Welcome, @smritiseb!

Is the older release completely shut down when the new one is brought up? Are you sure? How to check.

It is not possible to run two Galaxy instances on the same computer using the default configuration.

You are trying to access the web interface from the same computer, do you?
It’s possible your old version was configured to serve on the local network, but that is not the default for a new server.

1 Like

In terminal where is invoked both version shows same ip.(serving on if i type in the browser after invoking version) blank page is displayed whereas older version displays the galaxy page. Is this error has to do something with conda python?

1 Like

Please help.I am stuck with it. I tried editing the ip in config/galaxy.yml to my system ip then also its not
working. the title of the browser page is showing galaxy. but content is blank. Is there any log files to check the error?And when I checked the the config file of galaxy 18 config/galaxy.ini

its extension is .ini instead of .yml Is this error has any relation with the extension of config file?

Thanks in advance.

Ah, that may be an important bit of info. Galaxy is intended to be started with regular Python being available through the command python. If your python command invokes conda python instead, things can go wrong. Since you’re also saying that your browser is connecting to something, just nothing is showing up, my guess would be that something went wrong with Galaxy’s attempt to install JavaScript client code.
You may have gotten an error message about this, when you first started Galaxy, but maybe you didn’t notice.
You could attempt to fix the situation, but it’s probably simpler to just start over: clone Galaxy once more, but this time make sure you have python in your terminal point to standard Python 2.7 before you execute sh for the first time.

1 Like

i tried re-installing it.but still that error persists. The following lines are seen in terminal where galaxy is invoked
Starting server in PID 7777.

serving on

/home/cmfri/galaxy/.venv/local/lib/python2.7/site-packages/sqlalchemy/sql/ SAWarning: Dialect sqlite+pysqlite does not support Decimal objects natively, and SQLAlchemy must convert from floating point - rounding errors and other issues may occur. Please consider storing Decimal numbers as strings or integers on this platform for lossless storage.

‘storage.’ % (, dialect.driver)) - - [26/Mar/2019:14:29:43 +0600] “GET / HTTP/1.1” 200 - “-” “Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0”

[pid: 7777|app: 0|req: 1/1] () {36 vars in 630 bytes} [Tue Mar 26 14:29:43 2019] GET / => generated 95396 bytes in 99 msecs (HTTP/1.1 200) 3 headers in 266 bytes (1 switches on core 0)

[uwsgi-fileserve] security error: /home/cmfri/galaxy/static/scripts/bundled/base.css is not under /home/cmfri/galaxy/static/style/blue or a safe path

[pid: 7777|app: -1|req: -1/2] () {38 vars in 742 bytes} [Tue Mar 26 14:29:43 2019] GET /static/style/jquery-ui/smoothness/jquery-ui.css?v=1553590714 => generated 20147 bytes in 0

1 Like

Ok, one more attempt. Is Firefox 31 really what you are using? If so, that is really quite outdated. Have you verified that things aren’t working with a different browser?
Everything else you’ve pasted looks rather innocuous to me.


thank you so much Maier. your suggestion solved my problem.After updating firefox it worked perfectly.Thank you

1 Like