VCFfilter expressions are whitespace-sensitive

Hi! Im working on a filter to remove from VCF file reads with QUAL<40, I run VCF with Hg19 genome on a VCF generated by FreeBayes for variant calling, after aligning with bowtie2, I leave all the parameters as default an in the first filter option I write -f “QUAL>40” (I require a treshold of 40) but I get the following error:

An error occurred with this dataset:

cannot subtract objects of dissimilar types 4 4
What am I doing wrong?

Hi @aogazon,

this tool requires spaces around operators. Try: QUAL > 40 and it should work.
Also make sure you’re using the latest available version of the tool, which currently should be 1.0.0_rc3+galaxy3 on