Workflow stopped working after Galaxy went offline on 6/18/20

I have a workflow that was working well before Galaxy went offline on 6/18/20. Now I receive a green badge indicating that the workflow has been successfully invoked but the “Step Scheduling” and “Job Execution” are not advancing. Are other’s having problems with workflow or have I somehow broken mine.

1 Like

Hi @dsg11

There were some technical server issues earlier today but this is the only report of a workflow execution problem.

I don’t see any queued or stalled jobs in your account, and the few histories I checked have content that seems to match up with your workflows. The server updates would not impact how a workflow behaves (before/after restart) if there were no other changes.

However, I do see one workflow that was updated in the last two days (overlapping with the server restart) – if that is the problematic workflow, you might need to review it for construction issues. Perhaps unsaved changes? Or the noodles need to be reconnected to reset the metadata?

Let’s follow up from there.


Hi Jenna,
I checked my workflow invocations under the User tab and there are 11 in the “new” state: three dated 6/18, seven dated 6/19, and one dated 6/20 and they all have nothing indicated under the loading step state summary. Here’s a snapshot of part of the page:

Given that these appear to have stalled, how do I clear them out? Could their presence in the cue be causing a problem.

I just checked to see if the first step, Bam to Bed when I called this tool directly (not as part of the workflow) and it worked so I’ll rebuild my workflow from scratch.

If you can figure out what went wrong, it could be very helpful. Originally, I tried to have a workflow that converted fastq to bedgraph but that failed to start just like these ones that aren’t working.

Thanks, Dave

Hi Jenna,
I just ran through my BAM to BedGraph protocol by calling each step individually and successfully completed the conversion. I then used this to build a new workflow that I called BAM to BedGraph v2. I’ve invoked this (Invocation ID: 9688ea8f971091ec) and the tool is stuck at the loading step like the previous version of the workflow.

Hi, I am also running into the same problem. I executed the individual steps using different datasets and it works fine. but it fails to execute using workflow. and now i have so many pending on my user account.

Hello, I am also experiencing the same issue. I run a workflow that I created, it is successfully invoked but it remains in New state and it doesn’t seem to run… Is there a problem with the server? Or an individual problem with my workflow? I don’t have any error message either. Thanks!

@creino @dsg11 @Nahed_Darwish @simran.ven

Our administrator is working on the issue. Please leave the workflows queued and they will execute. If that advice changes, we’ll let you know.

More feedback once done.

Related Q&A migrated to this thread: Takes so long to run a workflow


All workflows queued ~ 2 weeks ago should have completed by now.

If not, please try a rerun now.