I tried to run a new workflow but it stopped scheduling at some point... seems like a better error message is in order?

here’s the workflow invocation in question:

I tried with the full workflow form and the new one - same result.
“Invocation scheduling failed because an unexpected failure occurred.”
here’s the relevant history if you want to reproduce this issue:

I was able to schedule the workflow successfully if it did not check the “attempt to reuse jobs” option.

Hey Brad, that’s a nice test case! We’re missing a join condition there, this shouldn’t be hard to fix, I’ll post back when it’s done.


Yes, that was indeed a missing join, sorry that took a while to get to the top of the priorities. Should be fixed in [23.1] Add missing join condition in job search by mvdbeek · Pull Request #16710 · galaxyproject/galaxy · GitHub and is live on usegalaxy.org.

1 Like

I spoke too soon…
invocation: 93dea09a28f88112 failed on main

1 Like

Should be fixed after [23.1] Fix job search query by mvdbeek · Pull Request #16714 · galaxyproject/galaxy · GitHub gets deployed. You get a golden star for identifying two bugs!


Looks like this is scheduled properly now.


However, it seem’s to recalculating everything despite my selection to reuse previous jobs.
Should the job reuse work in this situation?

I think it should? Can you reproduce it? Please create an issue on the github repo.