Creating QIIME2 artefacts

Hi everyone, I am still having a problem creating a QIIME2 artefact in galaxy. I have my paired end sequences and i have my metadata loaded up. All i need to do is combine them in QIIME2. The tutorial on this page Importing demultiplexed sequence data — QIIME 2 Cancer Microbiome Intervention Tutorial is pretty straight forward but it only teaches you to copy and paste the data from the website and not how to really create your own. Can anyone point me in the right direction or know who I can ask?

Kind regards

Hi @Martyn

I’m not sure exactly how to do this either. Suggestions were in the original post…

Were you able to reach the tool developer? Or get help at their forum? They are currently working to update this specific import tool last time we had an update here. Details for this also in the original post.

Xref: Import qiime2 artefacts? - #2 by jennaj

We might be able to help more here but would involve testing out options just like you would be (these tools are a bit special, with no test data/unit tests in the Galaxy wrapper yet). Since potential inputs can vary significantly, a real example is needed.

You could create a history with examples of what you have tried so far (with datasets undeleted) then we use that for more tests. No other data please – just the starting data and your tests isolated.

  1. Start over in a new empty history
  2. Clearly label each test (using tags please – leaving the original dataset names intact). If you give each of the starting datasets a #tag, that will propagate to the outputs. I also tend to copy/paste the tool version into tags on outputs when testing across versions.
  3. Use the smallest test data possible. Just enough to be representative.
  4. A history with just the inputs will not be enough. We need your examples of failures.
  5. Posting that back here is just one small slice of potential help.
  6. Sharing that at the QIIME forum with context (cross-link to this post) would probably get more help. Some Q&A there already has similar advice so check those methods first if you haven’t already.

Hi Jennaj, I have asked on QIIME forum and I have reached the Goeks lab and they just tell me to ask on here. I have used QIIME2 in the past and I know the metadata needs to match the sample. The tutorial really isn’t that helpful because it only tells you how to copy and paste some data that is already on the website.

Kind regards

Ah, Ok.

Then let’s proceed with the tests. Please set up the history and your test runs and I can work with you to choose the correct way to get the data in. But I’ll need something to start with first. This tool is newer to me but can probably diagnose technical issues that may come up versus data/usage, and sort out something to get it to work (assuming your data is supported). Should learn to do this anyway so would appreciate your help :slight_smile:

If this seems a bit overwhelming, that’s Ok. Open up the different options to see what is required. The naming of the sequences is important, but the form has guidance and will adjust those for you in some cases. Give that a try please.

Thank you Jennaj, this is where I am at now. Below is my QIIME2 metadata which i uploaded successfully.

and here is my collection of fastq files which have been paired

Now I need to create a QIIME2 artefact and following the tutorial from the website

https://docs.qiime2.org/jupyterbooks/cancer-microbiome-intervention-tutorial/020-tutorial-upstream/030-importing.html

So I do exactly that

And here is the error report in Galaxy.

I do not know why it is telling me the file has been deleted when it is clearly in my directory. If you have any suggestions let me know :slight_smile:

Kind regards

1 Like

Hi @Martyn

That looks like a tool problem on the server side.

ping @sargentl – do you recognize this error?

hello,

having had a look at the situation, i am still not entirely sure what’s happening; do you think you could provide steps to reproduce this so i can analyze the results as they happen? thanks!

Hi, thank you for getting back to me.

I copied and pasted my meta table into the upload function and set it as a qiime tabular. I then used the meta tabulate function to create the qimme qzv file.

I uploaded my fastq.gz files in the upload function by drag and dropping them from my computer and paired them together using the build dataset pair.

After that I tried to use the qiime import tools function to create the qiime artefact and I get the error which now says this:

If you want, I can pm you my login details so you can see.

Best wishes

It seems like this is a different problem from the one before – one is the apparent premature deletion of datasets, the other is an input issue for a qiime2 tool.

For the first issue, if you can point me in the direction of inputs i can use (or a tutorial, etc) will try to reproduce; as the admin I can watch the process closely. I would have yanked the data from your history directly but you practice good data hygiene and have already purged them.

Regarding the error you just posted, it seems like your input (a collection of pairs, e.g. a list of lists) is not playing nicely with your SampleData[PairedEndSequencesWithQuality] selection; judging by the selection name you’d think it would want exactly that, but it is complaining about being given a list (presumably, the forward/reverse pair sublist).

I noticed if you select ‘Associate Individual Files’ instead of ‘Use collection to import’, it seems to assume single files (it certainly doesn’t explicitly support selecting forward and reverse sequences). Perhaps it wants a naming convention for forward/reverse instead of a list? I am going to level with you, this is outside my wheelhouse as a Galaxy admin and just guesswork at this point. Not to bounce you around to another platform, but this is almost certainly a qiime2-specific issue; something about these initial conditions is causing the tool to expect single files and be given multiple. I had a look at the data types but didn’t gain much insight; this particular issue is probably best left to the qiime2 devs as they will understand these types more intimately. If it is indeed a Galaxy bug, I will need their response to know what to look for anyway.

Hi, Thanks again for getting back to me :slight_smile:
Here is a tutorial that I am trying to work from Importing demultiplexed sequence data — QIIME 2 Cancer Microbiome Intervention Tutorial

I can’t find where to upload as ’ Associate Individual Files’ Is it somewhere in the upload function?

Best wishes

Hello,

Thanks for the tutorial, I’ll have a look. Re: associate individual files: its in in the tool itself, under ‘Import sequences → Select a mechanism’:

Hi Sargentl, Thanks for your help. I have found this but I am not sure how to do it. It says to add element but what is that? Do I type the names of individual files?

Sorry for all the questions but it is quite confusing to work out why it isn’t working.

Questions are always welcome, that’s what this site is for!

We are well out of my wheelhouse here as a server admin, but it looks like the text entry is just to specify what name you want to give the data on import; the ‘data’ selection below lets you pick inputs.

My only remaining suggestions are:

  • check your inputs; do you definitely have data of the type ‘paired end sequences with quality’ in the ‘casava one eight laneless per sample directory’ format? (not that i know much about what any of that means)
  • maybe try to ask this in the qiime2 help forum, as this is a tool-specifics question beyond the purview of this simple server administrator

happy to try to answer any more questions you have, though the qiime2 specifics will be largely educated guesswork.

Thank you. I did already use the original QIIME2 to analyse my data but I want to start using Galaxy so I am trying to figure it out. I analysed my data as Paired End Manifest Phred33 with metadata but I have no idea how to do that in Galaxy because I am following the tutorial which shows casava one eight laneless per sample directory.

Best wishes

I ran through the tutorial you provided on the cancer server and was able to complete the qiime2 tools import step:

…whereas i was not able to do so with the inputs you generated. it seems telling that my data_to_import:sequences is a list with 82 items, whereas yours is a list of pairs. perhaps you need to revisit the logic in your rules-based uploading; what does your pasted table look like for the rules based uploader, and what column definitions did you use?

Hi Sergentl, Thank you for spending time on that. I actually didn’t use rule based uploading. The tutorial provides sequences which are copied and pasted from the site but when I did mine I just uploaded them normally from my computer and then just paired them together by using the pair dataset function and that is my list of sequences.

Best wishes

Hi sargentl, I changed mine from a list of pairs to a list just like in the tutorial and it still didn’t work. I have no idea what else to try now.

Kind regards

Hi Sargentl, I managed to sort it. It was such a simple thing i had not thought about and that is the names of my files had to have been in Casava format and they wasn’t.

Thank you for spending time to help me with this.

Kind regards

2 Likes

sweet, congrats!

1 Like

Hello Martyn, If possible, could you assist me with importing a Paired-End Manifest Phred33 file ? I’ve noticed that the documentation tends to favor the one-eight single-lane-less-per-sample format , and there’s very little relevant information available on YouTube.