Delayed installation from tool shed to local galaxy


I am using a local server to operate Galaxy.

By following the instructions in, I have successfully installed some tools and performed some analyses.
Yesterday I tried to install ‘bowtie2’ as I have previously done but the installation did not proceed. I left it overnight since I wondered if the installation requires sufficient time. However, on the terminal in which the Galaxy was running, the following output was continuously printed until this morning. - - [07/Sep/2020:09:26:38 +0900] “GET /api/tool_shed_repositories?name=bowtie2&owner=devteam HTTP/1.1” 200 - “” “Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:72.0) Gecko/20100101 Firefox/72.0”
[pid: 16491|app: 0|req: 1475/1499] () {38 vars in 753 bytes} [Mon Sep 7 09:26:38 2020] GET /api/tool_shed_repositories?name=bowtie2&owner=devteam => generated 2 bytes in 25 msecs (HTTP/1.1 200) 3 headers in 139 bytes (1 switches on core 0)

There isn’t any error message but I don’t think this is a normal situation. I tried to install other tools like blast2GO or bowtie_wrapper but the same things happened.
Is this just delaying on installation or there is some kind of error that I am missing?

Thanks for your help


I solved this problem.
Re-installing Mercurial was sufficient to solve it.

1 Like