Error in Plot LEfSe results, doesn't plot results for comparison of 2 classes

Hi all,

I’m getting an error when using the last step of the LEfSe galaxy module ( Plot LEfSe results). Error text posted below

Traceback (most recent call last):
File “/shed_tools/”, line 151, in
else: plot_histo_hor(params[‘output_file’],params,data,len(data[‘cls’]) == 2)
File “/shed_tools/”, line 54, in plot_histo_hor
if bcl: data[‘rows’].sort(key=lambda ab: fabs(float(ab[3]))*(cls.index(ab[2]) 2-1))
File “/shed_tools/”, line 54, in
if bcl: data[‘rows’].sort(key=lambda ab: fabs(float(ab[3]))
ValueError: invalid literal for float(): 3wo

I’ve encountered the same error before, but that was due to having more than 2 classes in the data. This set only has 2, and otherwise worked for a different subset that I entered just a few minutes prior.

Any help would be great, thank you so much!

Hi @Kevin_Rey

This part of the error message indicates that there is a problem with the input data to this step. Maybe check your data/settings again? Maybe the wrong column of data was selected for plotting. Or, there is an unexpected header?

You are also using a version of the tool that was sourced from the Test ToolShed, which means that it might not be “production-ready” or have unresolved development bugs. A better choice would be to install and use the versions of the tool suite from the Main ToolShed:

Hope that helps!

A post was split to a new topic: Errors using LEfSe tool through the Galaxy/Huttenhower lab website