error running trimmomatic

I get the following error when using Trimmomatic Galaxy Version 0.39+galaxy0. Using Galaxy Version 0.38.1 I don’t get the error.
Maybe its a problem with java versions?

Picked up _JAVA_OPTIONS: -XX:MaxPermSize=2G -Xmx6G -Xms1G -Duser.home=/data/2/galaxy_db/tmp Unrecognized VM option ‘MaxPermSize=2G’ Error: Could not create the Java Virtual Machine. Error: A fatal exception has occu

Hi @Michael_Thon

Are you working at If so, a rerun is usually enough to resolve cluster hiccups.

That said, the most current version of the tool at that server is this and is working Ok are far as I know, and seems to match your results: Trimmomatic flexible read trimming tool for Illumina NGS data (Galaxy Version 0.38.1)

Older versions of tool wrappers can certainly have problems that won’t be addressed. We keep those around for reproducibility reasons … but using the most current version is recommended for new jobs (update your workflow, etc). Sometimes the newer wrapper version is the fix for an older version.

Does that help or did I misunderstand anything? Thanks!

Hi, yes I’m using The latest version I see is “0.39+galaxy0”. Tomorrow I can send a screenshot and share my history.

Michael Thon
Professor (Catedrático de Universidad)
Institute for Agrobiotechnology Research (CIALE)
University of Salamanca

Hi @jennaj - I just ran the trimmomatic tool (latest version) again and it worked fine. Yesterday I ran it twice and got errors both times. Must have been a temporary problem with the cluster. Thanks for your help!

1 Like