Can't run any tool after weird problem with available disk space

Hi everyone!

Yesterday I had a problem with a memory availability calculation in Galaxy Europe. I was running Kraken and in the middle of it I got to 100% disk usage, I deleted everything related to Kraken but still. After contacting the support team via email, they suggested me to copy my data to a new history and purge the old one. This worked but it worked too good I guess, now I’m seeing a quota of -5% :crazy_face: my problem is that when I try to run any tool (Trimmomatic for example) I get the following:

Error executing tool with id ‘’: ‘NoneType’ object has no attribute ‘matches_any’
The server could not complete this request. Please verify your parameter settings, retry submission and contact the Galaxy Team if this error persists. A transcript of the submitted data is shown below.

“history_id”: “f7b4fd0f4de2700e”,
“tool_id”: “”,
“tool_version”: “0.38.1”,
“inputs”: {
“readtype|single_or_paired”: “collection”,
“readtype|fastq_pair”: {
“values”: [
“id”: “02e37b92dc9e1c5b”,
“src”: “hdca”
“batch”: false
“illuminaclip|do_illuminaclip”: true,
“illuminaclip|adapter_type|standard_or_custom”: “standard”,
“illuminaclip|adapter_type|adapter_fasta”: “NexteraPE-PE.fa”,
“illuminaclip|seed_mismatches”: “2”,
“illuminaclip|palindrome_clip_threshold”: “30”,
“illuminaclip|simple_clip_threshold”: “10”,
“illuminaclip|min_adapter_len”: “8”,
“illuminaclip|keep_both_reads”: true,
“operations_0|operation|name”: “TRAILING”,
“operations_0|operation|trailing”: “25”,
“output_logs”: false,
“output_err”: false

I tried purging the whole history and uploading the reads again but I get the same.

Thanks for any help!

Hi @Alan

You uploaded the reads into a new history, confirmed they are Ok (FastQC runs correctly), and this error still resulted from a fresh run of Trimmomatic loaded from the tool panel (not some rerun)?

The error indicates some problem with the collection of paired reads. Are those actually fastq reads? What happens if you uncompress those reads in Galaxy – does that work? If compression was a problem FastQC would have probably failed, too though. Odd.

I guess the purging was not enough, and you might actually need an EU admin. We can ping here @wm75 and you can ask at the EU chat, too, if you want. They will need at least your username, but a shared history link is better and provides all other details to an admin. Find the chat link at the bottom of that server’s homepage.

1 Like

Hi @jennaj

Thanks a lot for helping me through this. This error was indeed from a new run and not a rerun, yesterday FastQC worked fine. The reads were fastq, everything seemed fine, now I’m running Trimmomatic and it seems to be working (at least it started without an error) so maybe it takes a day or so for the correct purge of the datasets.

1 Like

Hey, great news! Sort of weird but if it is working now, I’ll take that as a resolution too :slight_smile:

I’m guessing the server was very very busy, and some data wasn’t quite ready to be used yet. Now, why or how that even happened is probably some corner case. But at least we now have a description of the problem should it start coming up more.

Then we can squash whatever the root bug is. I’ve seen it maybe five times total over 10+ years. A few others have seen it a few times but in slightly different contexts, and we just fixed one of those. Not easy to reproduce … needs a perfect storm.

I really appreciate all of the public follow up!

Hi @jennaj

Yes, great news indeed! As for the root of the problem, things can happen, even more in such a busy server, I completely understand. The important thing is that there’s always such a responsive team to help with any problem, I really appreciate it.
By the way, I was looking for some way to tag a comment as solution but I don’t want to tag mine since the solution came from you, if you have the time and want to briefly make a comment with the solution, I could mark it and close this issue.

Many thanks again!

It is fine to mark your own answer :slight_smile: As long as the thread is marked solved people will see the details. If you think this needs a clearer answer as a summary, feel free to create that too. I can come back and checkmark it.