FTP files are upload, but not detect by galaxy

Hi !
I created a personal galaxy server. I follow the tutorial : https://docs.galaxyproject.org/en/latest/admin/special_topics/ftp.html
My ftp server work correctly. When I upload files, I have : my account folder with my files. All work fine.
But galaxy don’t upload automaticaly them in the dataset folder, and I can’t use my files in galaxy. No option in galaxy to take ftp files.

In my galaxy.xml :
ftp_upload_dir: ‘/home/galaxy/database/ftp’
#ftp_upload_site: ‘’
ftp_upload_dir_identifier: email
ftp_upload_dir_template: {ftp_upload_dir}/${ftp_upload_dir_identifier}
ftp_upload_purge: true

Thank you

1 Like

Wecome, @studyfranco

Are the FTP loaded files listed in the Upload tool for the user account these were loaded under?

Loading data by FTP has two steps:

  1. Transfer the data by FTP, using the registered account login credentials (email and password, the same as used in the web interface).
  2. Log into that same account in the web interface, open the Upload tool, click on the “Choose FTP file” button, and check the box next to each file you want to move from the FTP area into a History.

Note that the files will start to appear in the Upload tool as soon as the transfer steps start. These will be partial datasets until the transfer is completed. So, double-check the FTP transfer is completely finished before moving the data into a History.

This FAQ has the process overview: https://galaxyproject.org/ftp-upload/

Screenshot the Upload tool with one file loaded via FTP but not moved into a History yet:

Hi @jennaj !

Thank you !

Sorry, but my local Galaxy don’t have the possibility to choose ftp file in the uploader. I think the problem are here.
How can I activate this possibility ?
https://youtu.be/j5HX_Jtf8XI If you want see what I have exactly.

It looks as if you were starting up the database at the same time you were transfering the data. But that is not core issue – if FTP is configured correctly, the button for FTP loaded data should be enabled in the Upload tool (whether you have actually transferred any data into that particular account or not).

Please share more details about your configuration: Galaxy version, FTP server, OS, etc.

My galaxy version are the 19.05 with those configuration.
I use proftpd 1.3.6b with those configurations.
Galaxy and proftpd are on a docker container, from bash:latest + python:2-alpine + gcc:latest
And my database are a posgreSQL on another docker container, with the basics configurations.

Thank you for your help

1 Like

Thanks – I asked at the Docker Galaxy Gitter channel to see if anyone recognizes what may be going wrong. They may answer here or there, and feel free to join in the conversation: https://gitter.im/bgruening/docker-galaxy-stable?at=5de6826e8e906a1c8d61e84e

I don’t use this docker project. I created my dockerfile

1 Like

I took a closer look at your galaxy.yml file. The problem may be the single quotes for this setting.

ftp_upload_dir: '/home/galaxy/database/ftp'

Try removing the quotes so the line is formatted like this:

ftp_upload_dir: /home/galaxy/database/ftp

Reference galaxy.yml.sample

I try your solution. But it don’t work.
I just uncoment "ftp_upload_site: " line. I add a domain name.
My line are like that : ftp_upload_site: ‘galaxy.docker.org

And the ftp upload work fine.

Thank you lot of for your help !