Generate a topology for the ligand


I keep getting this error on the screen, but I couldn’t understand why. Can you help me? I tried it on 3 different computers, but it always gives an error when it comes to here. I also watched the video about Tuturial, I do the same, but this error is always given. Very happy if you help

Hi @emrea

This is how to investigate an error in the full logs: Troubleshooting errors. It also explains how to share back a history link.

First … try a rerun if you haven’t yet. Some small fraction of jobs fail for random reasons at any cluster, not just at public Galaxy clusters.

If that is not enough help, we’ll need more details.

  1. Are you working with tutorial data, or your own data? Try with the tutorial data first since that will eliminate many variables when troubleshooting, and you’ll know the tool “works” and the problem is likely with your own data (format, content, possibly the overall size …).

  2. Exact link to the tutorial/section you are following where this is happening. To make sure we are looking at the same methods – plus more people will have that context to help out at this forum.

  3. Where are you working? public Galaxy server URL or describe if other. And, if somewhere else, you could first try at the server for this tool to compare what happens.

I became a member of and I am working on this link . I have carefully examined your Tuturial and even though I have done it at least 5 times, I always got this error in the same place. Then I tried to make my own examples and I was stuck in the same place and couldn’t continue. I changed my computer and it still gave the same error.
What I want to do is find rmsd and rmsf. My examples are attached.

Thank you for your hard work. I found your page to be very high quality, and I am sorry to see such an important page late. I have also attached my pdbs.

Best regards

(Attachment mycomplex.pdb is missing)

(Attachment receptor.pdb is missing)

(Attachment ligand.pdb is missing)

Hi @emrea

Try generating and posting back a shared history link instead. That provides more context. Make sure that the history includes your example error using the tutorial data and methods, and be sure to leave the inputs and outputs undeleted. If you already deleted, please recreate it.

Also … the Galaxy tutorial includes a workflow, so you might find what went wrong by using it with the tutorial’s data. That is a great way to quickly create a “reference history” for troubleshooting, any tutorial.

And just to confirm, please also post back this information. I can guess what you are following, but topics more useful as a troubleshooting reference when all the moving parts are clarified.

I can replicate the structure from the tutorial I’ve been following, but when I load these files separately, it always gives me the same error in the same place. The problem occurs during the ligand topology generation. The reason is that it assigns both HET and atom types as zero. Additionally, I cannot perform molecular dynamics simulations on the complex obtained from my own molecular docking results. What should I do to overcome this?

So the tool is working with tutorial data, and not with your own.

But you didn’t share the tutorial you are following. And didn’t yet share back a history. Both provide context for people helping out here.

The following tuturial:

When I use both ligand and protein separately(sometimes for protein, sometimes for ligand(drugs/peptide)). Always it is given this error.


Hi @emrea Great, thank you for posting back the details.

This looks like a problem on the cluster nodes running the tool. The mulled environment specifically is complaining. Have you rerun to make sure it wasn’t a temporary problem? Other reasons could include the data itself and runtime parameters – possibly too “large” or maybe missing expected features the tool is acting on.

The URLs appear to be from the server. Please send in a bug report to the EU team from the error, and then also confirm here so we can ping them. If you are working somewhere else, please describe.

Thanks for the followup!

I use this: .

When checked complex:
and make protein:
and when make a ligand:
it occur every time and ı don’t know why.

Did you try running the tutorial data through the tutorial’s workflow? is probably the best public server to use – but the top of the tutorial will list out where under “Available at these Galaxies”.

If that produces the same error, please share back a link to the history and imported workflow, and we can confirm then report the problem to the GTN. I don’t know of any current problems but maybe something new has come up.