GOseq Error--Duplicate Row names?

Hello, I am getting the following warning message:

Warning message:
In Sys.setlocale(“LC_MESSAGES”, “en_US.UTF-8”) :
OS reports request to set locale to “en_US.UTF-8” cannot be honored
Warning message:
replacing previous import ‘utils::download.file’ by ‘restfulr::download.file’ when loading ‘rtracklayer’
Error in .rowNamesDF<-(x, value = value) :
duplicate ‘row.names’ are not allowed
Calls: nullp … row.names<- → row.names<-.data.frame → .rowNamesDF<-
Warning message:
non-unique value when setting ‘row.names’: ’

I believe it’s saying that my issue is non-unique row names? I have uploaded two seperate files-- one containing gene ids & gene length, the other containing gene ids & boolean differential expression. I am not sure if it means the duplicate rows in my gene ids are a problem? I did not go through the galaxy training as I had the data already processed. Thanks.

1 Like

Hi @battagliad1

This error can also result from labels or data structures that the tool cannot interpret. It is a R tool that is very picky about format. The same error would result from using it line-command with the same inputs/parameters.

This is a good post about how to check the data, since it goes through a few tools, including this one, with common format troubleshooting: EdgeR row names error

Short list of things to check:

  1. No extra headers in either file. Remove if needed.
  2. Do the geneIDs have a .N (where N is a version number) attached at the end? Try removing the .version and confirm that all IDs are unique.
  3. Are the geneIDs in the same order between the two inputs?
  4. Some people have had success with filtering down both files to contain the same genes (only).
  • Technically, what is required is that each gene in the gene-true/false input is represented in the gene-lengths file (just one time, and that second gene-lengths file can have excess genes). But doing this can sometimes identify problems.

See Data Manipulation Olympics or that other topic above for how to do the data manipulations/comparisons.

Let’s start there, thanks! :slight_smile:

I see. I tried a few things but I am still having this same error. Maybe the problem is that my gene length has decimals?

I’m not sure but rounding those off is something to try.