HISAT2 runs successfully with 76% alignment reported but empty BAM file (71 bytes)

Hi, ran HISAT2 on some Illumina paired-end fastq files. Tool worked successfully on 22/24 fastq files, but on last pair, it finishes successfully, outputs a mapping summary (76% alignment) and BAM file, but the BAM file is empty (71 bytes). I reran the tool on just those 2 fastq files and got same result. Each fastq file is ~4GB and I have 34GB remaining on my user quota.

Is there any output in the stderr?

Yes, thank you. I should have included that. The stderr reads:
HISAT2 summary stats:
Total pairs: 55571644
Aligned concordantly or discordantly 0 time: 16538133 (29.76%)
Aligned concordantly 1 time: 33642601 (60.54%)
Aligned concordantly >1 times: 1959209 (3.53%)
Aligned discordantly 1 time: 3431701 (6.18%)
Total unpaired reads: 33076266
Aligned 0 time: 25972261 (78.52%)
Aligned 1 time: 6454889 (19.52%)
Aligned >1 times: 649116 (1.96%)
Overall alignment rate: 76.63%
[bam_sort_core] merging from 57 files and 1 in-memory blocks…
[E::hts_open_format] Failed to open file ./samtools.8893.3940.tmp.0023.bam
samtools sort: fail to open “./samtools.8893.3940.tmp.0023.bam”: No such file or directory

The first time I encountered the problem, I was running HISAT2 on a collection. All other datasets yielded the expected BAM files compatible with downstream analyses except the 2 I reran above. This initial attempt gave the stderr below:
[bam_sort_core] merging from 57 files and 1 in-memory blocks…
[E::hts_open_format] Failed to open file ./samtools.8889.4179.tmp.0054.bam
samtools sort: fail to open “./samtools.8889.4179.tmp.0054.bam”: No such file or directory

The other BAMs in the collection have different stderr output (example below) but again give valid BAM files:
[bam_sort_core] merging from 54 files and 1 in-memory blocks…
[E::idx_find_and_load] Could not retrieve index file for ‘/jetstream/scratch0/main/jobs/29607793/outputs/dataset_43103143.dat’
[E::idx_find_and_load] Could not retrieve index file for ‘/jetstream/scratch0/main/jobs/29607793/outputs/dataset_43103143.dat’

I have successfully reran HISAT2 on these two files. It is possible that there were an intermittent issue with the Jetstream compute resource.

OK, great, thank you! I will add the job to the queue and try again!

Oh, I see you added the run to my history, thank you very much for your help! I have canceled the job I added before seeing this.

As you have been so helpful, I have to press my luck and ask you one more question: I tried running Salmon quant and the job terminated with an error saying the Salmon tool needed to be updated. I have since deleted these jobs and cannot provide more information. Do you know if the Salmon tools need updates or if these jobs likely failed for another reason?

Thank you again,

Galaxy main has the latest version of the wrapper. It would be nice to see the actual error. Did you use pre-built salmon index?

No, I used 473: refMrna.fa.gz from my history. I will try rerunning tonight and if error happens again I will send it to you.