How to fix errors with Lefse

Traceback (most recent call last):
File “/galaxy_venv/bin/”, line 33, in
sys.exit(load_entry_point(‘lefse==1.1.2’, ‘console_scripts’, ‘’)())
File “/galaxy_venv/lib/python3.7/site-packages/lefse-1.1.2-py3.7.egg/lefse/”, line 90, in lefse_run
File “/galaxy_venv/lib/python3.7/site-packages/lefse-1.1.2-py3.7.egg/lefse/”, line 222, in test_lda_r
AttributeError: ‘NoneType’ object has no attribute 'rownames

The second step of running the lefes reported an error. How should I fix it

Welcome, @gao

Errors like this can be searched for across the internet, and usually find meaningful help.

Here is one example. It is an input error, and means that the tool expected to find data in an input table that it didn’t find. scRNA-seq: RS4' object has no attribute 'T'" in fastMNN R function

In the context of Lefse executed in Galaxy, that would probably fit what is going on generally.

And rownames indicates a problem with a label or header in an input file.

So, start by checking the format of your inputs – and any data entered on the tool form used as a label – for technical errors. Most tools parse singleword values better than those with spaces. Some can also interpret underscores. Most other characters are not accepted, and can lead to errors.

Please give that a try, and if you are stuck, provide more details:

  1. Where are you working? Public Galaxy server URL or describe if other
  2. Exact tool name including the version
  3. Screenshots or shared history links to give others an idea about what the inputs + tool form settings are that produce the error.
  4. How to find these details in Galaxy: Troubleshooting errors && What information should I include when reporting a problem?

Let’s start there, thanks! :slight_smile:

I have also been trying to perform a LEfSe analysis ever since yesterday and I get the exact same error. Problem is, I also get it when I upload the test data that are given in the tutorial page. Do we know if there is something wrong with the website in general? I also have been trying to solve it but I don’t know what to do and I cannot find a lot of help online. Another post also reported the same mistake yesterday.

Hi @Adelaide_Panattoni

Have you tried to ask at forum the server hosts? It is linked from that server’s homepage and is the only way to contact them as far as I know.

This threads and a few others have details. I’ve also added a tag to this post that will find more (guessing that was the server where the original question asker was working).

Hope that helps, and if someone does make contact and gets feedback, posting back the solution would be helpful here, too :slight_smile:

Update: I just did a search at that forum and see some open questions about this same issue. Maybe also report the problem to that same thread? They are likely working on it but more user feedback seems helpful. Xref: LEfSe issues and errors - LEfSe - The bioBakery help forum