How to run specific tools on GPU?

As the Galaxy tools use the CPU, but some of the tools (GROMACS) and similar are able to use the GPU for better performance as well.

Is it possible to run the galaxy or specific tools on GPU?

Kindly suggest some tutorials or help to run GROMACS on GPU through Galaxy.

1 Like

@vmevada102 yes this is in theory possible. However, at least the European Galaxy server has way more CPUs than GPUs. This means while a single user can maybe profit from GPU support we can run more jobs in parallel on CPUs at the moment. So overall all users profit currently more from CPU-Gromacs.

If you really need GPU because you are running a bigger project please get in contact with us and we can find a solution. The crucial part is to setup a container with GPU support and GROMACS that can run on the given infrastructure. This is not really a Galaxy problem.

Hope that helps a little bit,

Thanks for your reply,

Sometimes, GROMACS required 1 day or more than that to run the job on CPU. If we can process it using GPU, we might be reducing the time period to run such jobs.

There are serveral users having their own system with more GPU. They might be also benfited like me.


Hi bjoern.gruening,

We discussed the usage of the Gromacs on GPU.

If you have found some resolution. Kindly share with me to run this on my server as well.

We have dedicated NVIDIA GPU card for the calculations.

Can you submit jobs to your GPU host? We have created VMs ontop of our GPUs, so that every VM just get one GPU. Then we simply submit jobs into those VMs.

Hi bjoern.gruening

Actually, we have NVIDIA GPU (Tesla K40c). All CUDA drivers were installed properly in the system.
The system consist one Galaxy installed run the programs in local system.

But unfortunately, The galaxytools does not recognise the GPU in the system. Or there might some configuration to detect(utilise) the same.

As Gromacs Simulation Version 2020.4+galaxy0 in the new parameter available. " Job Resource Parameters" Stating the information to execute command on GPU.

However, this parameter was not available in my local system with the same version of tool installed in the system.

Please help me run the same on the GPU available in the system


what you see on EU is a special Galaxy feature. You can add some additional parameters to a tool form that can influence where your tool is executed, here GPU or CPU.

Please set the ENV var in your Galaxy destination to GPU_AVAILABLE=1 and than the tool should use it. I will loop our expert @simonbray in so that he can make sure I don’t say stupid things.

Please set the ENV var in your Galaxy destination to GPU_AVAILABLE=1 and than the tool should use it. I will loop our expert @simonbray in so that he can make sure I don’t say stupid things.

No, I think this is accurate. It’s cool that you’re trying to get the GROMACS tools set up with GPU @vmevada102! Let us know about your progress.

Thank you for kind support @bjoern.gruening & @simonbray,

I am core programmer, so, some confusions will be raised as if.

However, It looks silly question regarding GPU. But the feature you have set is extraordinary to analyse our data with GPU.

As per the suggestion, I have added the GPU_AVAILABLE=1 in the Variable. But still have problem,
The option of choosing parameter for GPU is missing in our local Galaxy,

So, is there any specific configuration or change some parameters to enable this feature in Local Galaxy.

Without his selection option, i am not able to proceed further.


Yes, this is a general Galaxy feature.

Please have a look at this file: galaxy/job_resource_params_conf.xml.sample at dev · galaxyproject/galaxy · GitHub

And here the part for the job_conf.xml file. galaxy/job_conf.xml.sample_advanced at dev · galaxyproject/galaxy · GitHub

Please also note that we have the entire confuration online on GitHub. See here for example: infrastructure-playbook/job_resource_params_conf.xml at master · usegalaxy-eu/infrastructure-playbook · GitHub

Hope that helps,

1 Like

Thank you Bjoern for your informative reply,

I am trying to follow your resolution.