Keep getting an error when trying to use CANU assembler with Oxford Nanopore reads

Hi everyone,

I am trying to assemble a bacterial genome using CANU from sequencing data obtained on Minion Oxford Nanopore. The minion gave me 786 fastq files of data. I created a list collection of these fastq files. Every time I pass on the collection to the CANU assembler, I get an error message.

Can someone please help me with this? am I passing the right data format to the assembler ?
Thanks

Pax

1 Like

the error says:

“error
An error occurred with this dataset:”

Hi @pax

Troubleshooting options:

  • Try comparing your inputs to the test data included in this prior Q&A. I understand that your data is in a collection, so check the fastq elements inside the collection and your tool form settings. Nanopore data assembly with CANU

  • Make sure your collection is formatted correctly. All elements should have the same datatype assigned, and actually have content that matches that datatype. Collection tutorials: https://training.galaxyproject.org/training-material/topics/galaxy-data-manipulation/

  • If the inputs are formatted correctly and the tool form settings match the content, the job could be failing for resources. Is this your own Galaxy server or some public Galaxy server? If public, what is the URL?

Let’s start there, thanks!

Hi @jennaj

Thanks for your answer. I am using “https://usegalaxy.eu
I just retried the assembly using the E.coli Oxford Nanopore test data from the CANU website in galaxy and I am getting again the same error message.

This is a link to the history with test data that I tried and the error files returned:
https://usegalaxy.eu/u/pax/h/test-data-from-canu-website

Best,

Pax

1 Like

Thanks for clarifying. The history does not have permission granted to review the datasets inside the history but it sounds like you set up the test correctly.

I also started some test reruns (4 different tests: datasets 13-32). The tool wrapper version updated from 1.7 to 1.8 since the initial runs. The new tests cover both tool versions with both sample input types. Everything is tagged. The jobs are still executing: https://usegalaxy.eu/u/jenj/h/copy-of-test-canu-nanopore-fastq-with-reruns

There may be some problem server-side (known or unknown). Let’s check with the Galaxy EU admins – ping @wm75 @bjoern.gruening

1 Like

Hi @pax,
the jobs in @jennaj’s test history all finished successfully. However, the jobs she executed with canu version 1.7 did so only after automatic resubmission on intial failure. On usegalaxy.eu, failing job runs are retried once with 1.5x increased memory available to the tool. The fact that the jobs with 1.7, but not those with 1.8, had to be given more memory could mean that version 1.8 is more memory-efficient.
Now I don’t know whether memory is at all the issue with your jobs, but if it is, rerunning them using the latest version of the tool could be a solution.
If that doesn’t help, it would be great (as @jennaj pointed out already) if you could give access also to the datasets themselves in your shared history. You should see a corresponding checkbox on the “Share” page.

1 Like

Hi @jennaj and @wm75,

Thanks you so much for your help. I re-ran the nanopore test data and it worked this time. I was already using the 1.8 version for the first time I tried when it failed. Unfortunately, I retried my own data and it failed again. I am starting to wonder if it is my data that is the problem. The test data was a single fasta file, my files are 786 fastq file (obtained directly from the minion) that I combined into one collection. I was wondering maybe If I could share the collection with you to see if something is obviously wrong with it but somehow I cannot see it. I am not sure I understand how I can grant permission to review the dataset inside the history. Can someone guide me how ?

Best,

Pascal

hi @jennaj and @wm75,

Finally CANU started running on my samples without giving me an error message after 10min but so far it has been running for almost 2 weeks. I was wondering if that was normal or if it’s just stuck ?

Thanks,

Pascal