Nanopore data assembly with CANU

Hello,

I’m trying to run an assembly on Nanopore raw reads (fastq) with the Canu 1.7.1 assembler. I tried on different servers, with my data and with public nanopore data from EMBL-EBI. I’m getting an error message from the tool every time : “Fatal error: Exit code 1 ()”.

Can someone tell me if the tool works or if it’s coming from me.

Thank you

1 Like

Hi - Not sure if you worked the usage out or not yet, but I just tested the tool with some sample data from the tool author and everything processed fine at Galaxy EU https://usegalaxy.eu.

Shared history: https://usegalaxy.eu/u/jenj/h/test-canu-nanopore-fastq

Expand the history annotation to see where I got the datasets and example command-line options. For the test jobs, I mapped over the command-line options to the tool form options without any other changes.

Hope that helps!

Admin edit 7/6/2019: Corrected shared history link name URL “name” (active URL was ok) but did need to reset history share status.

Hello, I recently tried to run an assembly with CANU on Minion trimmed reads (trimmed with Porechop).
I had three different dataset, 1 small dataset (~30.000 reads) and two bigger datasets.
The small dataset ran successfully. For the second dataset I got an error after about 30 hours “Fatal error: Exit code 1 ()”
The third dataset is still running, after 1 week…

1 Like

Pinging the administrators of the Galaxy EU server. Please be patient for a reply as they are hosting the annual GCC conference right now. @hxr @bjoern.gruening

Also, I reset the share status for the history in my original reply, although I do not think it will help for your specific problem given the error description.

@michele.dellab can you send me an error report from Galaxy on the usgalaxy.eu instance. I need more information to debug this.

Thanks!

1 Like