Lefse input problem resulting in error "IndexError: list index out of range"

I am so sorry to bother you to help me solve this problem. I wanna do the Lefse analysis, the first step of format data seems failed . I can’t get the point about the error. I would be so appreciated if this will be solved. Thx!!
Traceback (most recent call last):
File “/shed_tools/testtoolshed.g2.bx.psu.edu/repos/george-weingart/lefse/a6284ef17bf3/lefse/format_input.py”, line 429, in
class_sl,subclass_sl,class_hierarchy = get_class_slices(zip(*cls.values()))
File “/shed_tools/testtoolshed.g2.bx.psu.edu/repos/george-weingart/lefse/a6284ef17bf3/lefse/format_input.py”, line 145, in get_class_slices
previous_class = data[0][0]
IndexError: list index out of range

1 Like

Hi @Emma

That said, this error in technical terms means that the tool is looking for specific data in part of the input that isn’t being found. There is probably some problem with the column or row selected for the option “Select which [row|column] to use as subclass”.

Try double-checking your tabular input (first option on the tool’s form) to make sure there is content in the row or column you selected. Tutorials and example data are hosted on that public Galaxy server for comparison. Scoll down on that tool form for an example of input data organized by rows.

Hope that helps!

Really THX!I have solved this problem by using the method you mentioned above.