Local account vs. Galaxy account vs. admin account and login not working


I’m attempting to install a local version of Galaxy on a centos VM. In order to get admin rights to the instance, it said I have to have a registered account. I had one under one email, but the local galaxy install will not authenticate it. It authenticates fine when I login to the main public galaxy site.

I then registered a new account under a different email address (yeah I know, but it’s broken so what am I supposed to do). I made that account an admin, then I deleted the original account. Then I tried to re-create the account, or just login, in the local instance but no luck as it says my email is already registered. I tried logging in as a registered user on this local instance, tried creating a new account, and also tried to create a user from the admin interface and none of them worked at all.

How does this actually work? When a user authenticates to a loopback based local instance, is it actually checking somehow against your main registration server? How do I have local users and also have an admin user? How does any of this work? If it’s documented clearly somewhere, please advise as I searched the help and faqs and came up empty.

At this point I’m just trying to test this thing and see if I can actually get it running on a VM for a user, I’m not a genomics guy I’m a sysadmin.

From what I can tell, once a person registers an email address with you centrally, you can never use that email again on a local user install. So even though it’s local it phones home to mama to see if the user exists? It just keeps saying that the account exists already, but won’t actually authenticate to it because the password doesn’t work. So how do local users even get created and managed? It requires an email address no matter what. This is for my local install of galaxy not y’all’s system.

I’m seeing some suggested topics to browse and will try those but any help or links or suggestions at all will be greatly appreciated.
Thanks -

Update - reinstalling galaxy on a different machine, I was able to re-register my account. It also has admin privilege.

From what I can tell, the local galaxy install keeps the user account and password hash local in the database, but does check the email address against the global galaxy system to see if the user is registered with galaxy? This would explain why I was getting errors trying to re-register since it probably had a local db entry for my userid that the system didn’t clean up, even after I deleted and purged the account.

Would still like to understand how the admin piece works - that actually checks an email registration entry on you all’s central public galaxy system?

Hi crh

Just to confirm, a local installation does NOT “phone home to mama”

Regards, Hans-Rudolf


There is no primary “Galaxy” instance. Various institutions provide compute resources managed by their own deployment of the Galaxy software. If you are thinking of “usegalaxy.org”, that is only one of many public instances of Galaxy. It just happens to be maintained by one of the same institutions that develops Galaxy. Galaxy does not attempt to connect to any other instance, with a few exceptions, and it must be explicitly configured to do so in those instances.

To give a user account within an instance of Galaxy admin privileges, you must add that users email address to the list of admins in your Galaxy config: https://docs.galaxyproject.org/en/master/admin/config.html#admin-users


Thank you both for your replies. I understand now, I had been under the impression that an admin had to be a “registered user” and that the “registered user” had to be registered centrally with the usegalaxy.org site in order to access the tool installs, etc. Rather, it seems that an admin user just has to be registered locally on that galaxy instance, and added to the config file’s admin list - which completely makes sense.

1 Like