Question: Do you need root access to become an admin in a local Galaxy? Answer: Not needed

Hi Everyone,

Very new to galaxy. I’m using my university’s big computer called OSCAR to run galaxy, and I’m having a few issues. I was able to install and run galaxy so I had my own instance. However, some sources say I need to become a root user of the computer to be able to make myself admin and restart galaxy so that I can add tools, but I’m not allowed to have root access. (for the record, galaxy is in its own directory within home) I was able to add myself as an admin in the galaxy.yml file and restart without using “sudo” but I’m not sure if that’s good enough. there are no options for admin on my galaxy instance. Is it possible to make myself a galaxy admin without root? I can’t use docker on OSCAR for the same reason. Additionally, partially because I can’t become admin, I can’t import the toolshed I need, mentioned in this page: https://snvphyl.readthedocs.io/en/latest/install/galaxy/#overview I really need these SNVPhyl tools for my project. Can anyone help me with these problems?

Best,

CS

1 Like

Hello,

It is definitely possible to run Galaxy without being root. And having root access has nothing to do with becoming “an admin” in Galaxy.

I added at few tags to your post, including “become-an-admin”. Review the prior Q&A with same links to find out how to get set up with a basic local install with admin configured. You’ll also find more links to our FAQs, tutorials, and help for advanced configuration.

Thanks!

Hi there,

I can’t find the Q&As and FAQs you’re talking about. I was able to set up a local install of galaxy, but when I tried to become admin I did not notice any changes. Could you provide some links to send me in the right direction? I haven’t been able to figure out how to become admin, so I would really like some instructions.

A good start is here: https://galaxyproject.org/admin/get-galaxy/#configure

Another set of related questions is reachable via the tag Jenn has added: https://help.galaxyproject.org/tags/become-an-admin

I’ve tried both of those things, and the account I made still doesn’t seem to be an admin. I don’t know what I’m doing wrong…

this is what I have in the galaxy.yml file

#Administrative users - set this to a comma-separated list of valid
#Galaxy users (email addresses). These users will have access to the
#Admin section of the server, and will have access to create users,
#groups, roles, libraries, and more. For more information, see:
#https://galaxyproject.org/admin/
#admin_users: ‘’

admin_users: myexampleemailaddress@gmail.com

#Force everyone to log in (disable anonymous access).
#require_login: false

Have you restarted your Galaxy?

Yes! I’ve closed the window and the terminal and then re-opened it. is that how you restart it, or is there some other special way to do it?

You might have just killed the script that runs the Galaxy but not the process. To properly finish the process use ctrl+c in the terminal where Galaxy is running (assuming you start it with run.sh script).

Use something like ps aux | grep uwsgi to see whether the Galaxy process has stopped.

Ok I did that, and I still don’t see anything different… where should I look for the admin stuff?

[cs46@node405 galaxy]$ ps aux | grep uwsgi
cs46 8390 0.0 0.0 112652 972 pts/7 R+ 10:52 0:00 grep --color=auto uwsgi

this is what I got after doing ctrl+c and using that script…

Now start your Galaxy again and log in using the admin user email and password.

I did and nothing seemed to change…

Could you share your galaxy.yml through a gist or similar service? Remove your passwords before sharing.