Local Galaxy GIEs: get in jupyterlab throws error


When trying to use the get method in a Jupyterlab I see this:

(base) root@b049c3385e8d:/storage/galaxy/jobs_directory/001/1474/working/jupyter# get -i 2730
/opt/conda/lib/python3.8/site-packages/bioblend/galaxy/histories/__init__.py:120: FutureWarning: The history_id parameter is deprecated, use the show_history() method to view details of a history for which you know the ID.

And no file is uploaded.

What would be the places to check to solve this?

1 Like

Hi @maikenp

Help resources:

Maybe check to make sure your command matches the format in the tutorials? If it does, then you’ll need to go through the configuration steps in the admin doc to make sure nothing was missed.

If you need more help, would you please share more details about your local Galaxy configuration? Include what you have done/checked so far. If this worked before, has something changed? Or is this is your first time using it?

yes, sorry for being rather sparse in the initial post.

We have successfully set up our galaxy instance and have been running notebooks in it for a while. We had issues with put() that were solved, but did not try get() until now.

It is typically the simple routine in Anne’s tutorial we are trying now: JupyterLab in Galaxy

Otherwise things work as they should. I.e. the notebooks run as they should, we can put files back into the history. But issuing get() gives the message shown.

I will have a closer look at the admin docs, and compare with our setup.

Yes, so the problem was related to collection datasets. I realized I had to unhide to get the id of each of the items in the collection, as get does not work on a collection.

Realized by looking closer at the tutorial JupyterLab in Galaxy where it does indeed inform about unhiding hidden datasets.