Local Galaxy tool install troubleshooting

I got the same problem.
is there any solution to fix it?

Welcome, @bertman

The prior person’t problem wasn’t very clear. Why a tool will not install could be for many reasons. The links to the admin training documentation, and the dependency resolver docs, are where to start. Those documents are the same as used during administrative training events, and one was happening this week so they are definitely current.

What tends to work best:

  1. Local OS is up to date. Any third-part software meets the minimum required by Galaxy (Python, Postgres).
  2. The most current version of Galaxy
  3. Use the default Conda dependency resolvers (at least at first)
  4. Install the most current version of tools

If you are completely new to system administration or this is for personal use, consider using the Docker Galaxy. Much will be preconfigured, and minor tuning adjustments have dedicated instructions with a Gitter chat, see Galaxy Docker - Galaxy Community Hub

I’m going to move this into a new topic. Please share more details if you need more help.

Thank you for your response
actually I’m still very newbie in galaxy.
I tried every tutorial and still got the dependencies installer stuck.

Hi @bertman

You are trying to install several repositories at the same time on a local server. The data transfer takes time (depends on your internet) and then installation of the primary tool and fetching/downloading/installing dependencies takes time.

Some completed, and some are still running. That is expected.

What is left is still a heavy load. Try giving it more time. If you tried to install all (53 + 6) all at once, and this is the remainder, and no movement at all for over a day or so, then probably yes, your server could be “stuck” :slight_smile: Just cancel what is left and start over with just those.

Batch installs are supported by this optional plug-in manager. I think it installs serially and throttles when the load is high to avoid dropped data but haven’t used it recently. You could try it next time if that is not already what you are using.

Hi @jennaj
I have tried to install them one by one, but the install tool dependencies still stuck.
Is there another way to fix it?

Which repositories get stuck? The exact tool id that includes the version please.

The server logs for that operation would also be helpful, and may help you to see what is going wrong.

This assumes that you have restarted the server to clear any old/dropped processes. If not, please do that first when testing. That should also give you somewhat cleaner logs.