Persistent error trying to run pipeline

I keep getting this error and even after modifying the pipeline, I cannot seem to solve it.

I would appreciate your input!

The server could not complete the request. Please contact the Galaxy Team if this error persists.

“new_history_name”: null,
“history_id”: “91206a3980e8b8b7”,
“resource_params”: {},
“replacement_params”: {},
“parameters”: {
“0”: {
“input”: {
“values”: [
“hid”: 71,
“id”: “11ac94870d0bb33a7fdb3635ba2e3cf8”,
“keep”: false,
“name”: “SRR13797175 (fastq-dump)”,
“src”: “hda”,
“batch”: false
“1”: {
“singlePaired|sPaired”: “single”,
“singlePaired|trimming|trimming_select”: “”,
“singlePaired|three_prime_clip_R1”: “”,
“params|settingsType”: “default”,
“rrbs|settingsType”: “default”
“2”: {
“singlePaired|sPaired”: “single”,
“refGenomeSource|geneSource”: “indexed”,
“refGenomeSource|GTFconditional|GTFselect”: “with-gtf”,
“refGenomeSource|GTFconditional|genomeDir”: “hg38”,
“twopass|twopassMode”: “None”,
“twopass|twopass_read_subset”: “”,
“twopass|sj_precalculated”: “”,
“quantmode_output|quantMode”: “TranscriptomeSAM GeneCounts”,
“quantmode_output|quantTranscriptomeBan”: “false”,
“chimOutType”: “”,
“oformat|outSAMattributes”: [
“oformat|HI_offset”: “1”,
“oformat|outSAMprimaryFlag”: “OneBestScore”,
“oformat|outSAMmapqUnique”: “60”,
“filter|basic_filters”: null,
“filter|output_params2|output_select2”: “no”,
“algo|params|settingsType”: “default”,
“perf|outBAMsortingBinsN”: “50”
“3”: {
“contaminants”: null,
“adapters”: null,
“limits”: null,
“nogroup”: “false”,
“min_length”: “”,
“kmers”: “7”
“4”: {
“strand_specificity”: “1”,
“anno|anno_select”: “builtin”,
“anno|bgenome”: “hg38”,
“format”: “tabdel_short”,
“include_feature_length_file”: “false”,
“pe_parameters|fragment_counting_enabled|fragment_counting”: “”,
“pe_parameters|only_both_ends”: “false”,
“pe_parameters|exclude_chimerics”: “true”,
“extended_parameters|gff_feature_type”: “exon”,
“extended_parameters|gff_feature_attribute”: “gene_id”,
“extended_parameters|summarization_level”: “false”,
“extended_parameters|multifeatures|multifeat”: “”,
“extended_parameters|mapping_quality”: “0”,
“extended_parameters|exon_exon_junction_read_counting_enabled|count_exon_exon_junction_reads”: “false”,
“extended_parameters|long_reads”: “false”,
“extended_parameters|by_read_group”: “false”,
“extended_parameters|largest_overlap”: “false”,
“extended_parameters|min_overlap”: “1”,
“extended_parameters|frac_overlap”: “0”,
“extended_parameters|frac_overlap_feature”: “0”,
“extended_parameters|read_extension_5p”: “0”,
“extended_parameters|read_extension_3p”: “0”,
“extended_parameters|read_reduction”: “”,
“extended_parameters|primary”: “false”,
“extended_parameters|ignore_dup”: “false”,
“extended_parameters|R”: “false”,
“extended_parameters|count_split_alignments_only”: “false”
“5”: {
“results_0|software_cond|software”: “star”,
“results_0|software_cond|output_0|type|type”: “log”,
“title”: “”,
“comment”: “”,
“flat”: “false”,
“export”: “false”,
“saveLog”: “false”
“6”: {
“results_0|software_cond|software”: “fastqc”,
“results_0|software_cond|output_0|type”: “data”,
“results_0|software_cond|output_1|type”: “data”,
“title”: “”,
“comment”: “”,
“flat”: “false”,
“export”: “false”,
“saveLog”: “false”
“parameters_normalized”: true,
“batch”: true

1 Like

Hi @Aya

This is showing up in a red pop-up window, correct?

If so, this usually means that the server is busy or restarting. It tends to not last very long. Refreshing your browser window to clear the cache will usually resolve the problem (wait for it a few minutes if it doesn’t resolve originally).

If you are not logged into an account, do that first (login). Why? The new_history_name variable seems odd for a registered account, but there have been some recent changes around that.

Should this still be happening right now, three days later, while logged in and after clearing the browser’s page cache, something else is wrong.

The first thing to check is the workflow itself (if I guessed correctly). Try editing it – does it open? Are all the steps connected, including the input/inputs? Do you see any warnings? What happens if you save a fresh copy (save-as with a new name) of the workflow and try to run that?

Should that not help:

  1. Is this how the problem is actually presenting (red pop-up, usually from clicking on “submit” on a tool form or a workflow – and yours does look like a workflow submit)? If not, please explain what is going on right before this happens, what triggers it, and where/how the error is displayed.

  2. And if this IS what is happening, still, after you tried the fixes above:

  • Are you working at a public Galaxy server, which one? URL?
  • If working with Galaxy in a different way (your own, some other private server, etc), please describe. That said, if a private server, the administrators running it would be the best people to help/provide some answers.

Let’s start there :slight_smile: But, hopefully, this is already resolved.

1 Like

Thank you very much for such a detailed reply :slightly_smiling_face: I will try out the suggested approaches and will update!

I ran another pipeline (HISAT2) instead of RNA STAR (same data set, same QC steps). It works no problem. Whenever RNA STAR is being run, the above error pops up. So there might be some other conflicts with the server when maybe the workflow tries to initiate STAR image?

1 Like

Maybe the RNA STAR tool needs to be updated in your workflow?

Another common fix is to disconnect all the “noodles” between tools, then connect again starting from the inputs down through the tools in the order of processing. This resets the workflow metadata.

Please give those a try and let us know if need more help :slight_smile:

Thank you very much for your kind help :slight_smile: , I will definitely give it a try and post the results here. Regarding the RNA STAR version, I think it should be up-to-date, I constructed the workflow a week or so ago.

Thank you again very much! :slightly_smiling_face: