Picard indexer (Fatal error: Exit code 1)

I’m writing as I’m attempting to import a reference genome into my Galaxy server, which has previously been successful, however, when reaching the step where Picard Indexing has to occur I’m running into an error. Specifically, I see the Fatal error: Exit code 1. It to me seems like it thinks I do not have a correct version of the tool Picard index, but I’ve attempted to download all varients without luck. I’m not sure what I’m missing? I hope someone can help.

Hi @asta

This post has the best way to run these: Indexing reference genomes with Data Managers: Resources, tutorials, troubleshooting

Few questions to start with:

  1. You are running Data Managers on a local install of Galaxy? Or is this a docker or cloud Galaxy?
  2. What version of Galaxy? Where was it sourced? The URL would be helpful or explain.
  3. What version of the fasta index DM did you run?
  4. Did you create a new database key or use one that was already available?
  5. Did you provide a fasta file from the history or did you look one up (and from which source)?
  6. Did you allow that to completely finish successfully before running the Picard index DM?
  7. What version of the Picard index DM did you run?

Let’s start there.

1 Like

Yes, the link is in fact from one of my own previous posts, where you of were of great help :slight_smile: However, this is exactly why I’m confused; I got it to run previously with your instructions but now it appears to not work. To answer the questions:

  1. It is a university server so there should be plenty of space.
  2. galaxy.pharm.nottingham.ac.uk
  3. The successful SAM FASTA index I ran was 0.0.1 (toolshed.g2.bx.psu.edu/repos/devteam/data_manager_sam_fasta_index_builder/sam_fasta_index_builder/0.0.1)
  4. I’m not sure what you mean by database key, but since I’m using a university server nothing was there previously, I’ve downloaded all tools and data managers myself
  5. I used Create DBKey and Reference Genome first (toolshed.g2.bx.psu.edu/repos/devteam/data_manager_fetch_genome_dbkeys_all_fasta/data_manager_fetch_genome_all_fasta_dbkey/0.0.3) with Mouse Dec. 2011 (GRCm38/mm10) (mm10) from UCSC
  6. Yes the SAM FASTA tool had finished successfully before I tried Picard index
  7. The Picard version that’s currently failing for me is 0.0.1 (toolshed.g2.bx.psu.edu/repos/devteam/data_manager_picard_index_builder/picard_index_builder_data_manager/0.0.1), I have tried to download all available versions to me in the toolbox.

Thank you!