planemo shed_update fails with "exceeds the server's configured size limit"


I’m trying to update a tool in the test tool shed of our local Galaxy ansible install. I have done this before in I think the same way, but it’s failing now and I don’t know why.

I have a local .shed.yml file in a directory with some tools. I have a repo associated with that directory that planamo can pull from.

I’m entering on the command line in the tool directory:
planemo shed_update --check_diff --shed_target testtoolshed --shed_key

I get the following error:

Size limit exceeded.
This request could not be completed since it exceeds the server's configured size limit. For help, please contact an administrator.

Repository metadata updated successfully for repository ‘tomo’ on the test Tool Shed.
Failed to update repository contents for repository ‘tomo’ on the test Tool Shed.

Can someone help me to figure out what is happening?


Hi @rolfverberg

I’ve cross-posted your question over to the Admin chat for help. They may reply here or there and feel free to join the chat, add more context, etc. Thanks!

1 Like

What repository is this?

The repo is at: GitHub - rolfverberg/galaxytools

However, I got a little further. I found that my API key was outdated. I tried to create a brand new tool and that worked fine, yay :slight_smile:

But when I then tried updating the tomo tool I got a new error:
Could not update tomo
Unexpected HTTP status code: 400: {“err_msg”: “You do not have permission to update this repository.”}
Unexpected HTTP status code: 403: {“err_msg”: “You are not the owner of this repository, so you cannot administer it.”, “err_code”: 403005}
Failed to update repository contents and metadata for repository ‘tomo’ on the test Tool Shed.

This is kinda weird to me, since I’m listed at the testtoolshed as the owner under tomo.

Add now I get the same error trying to update the tool that I successfully created just last week.

2 posts were split to a new topic: Troubleshooting tool development: making updates to a ToolShed