Problem during workflow importing "Uncaught exception in exposed API method"

Hi, I accidentally deleted a workflow I was using. Now I am trying to import my workflow from my computer and Galaxy gives an error as “Uncaught exception in exposed API method:”. Do you have any idea how could I solve this problem?

Hi @Serkan_ONDER
Maybe try this: Workflow (the top Galaxy menu) > Toggle Advanced Settings (double arrow icon at the right end of the search bar in the middle window) > tick/mark Deleted box > restore the deleted workflow.
Hope that helps.
Kind regards,


Dear Igor, Thanks a lot. The problem is that I deleted one part of the workflow and than I saved it. I tried to restore the workflow as you mentioned but it is not possible to recover deleted part of the workflow. So now I am trying to setup new workflow from the begenning.

Hi @Serkan_ONDER

Workflows are versioned. You should be able to navigate back to the prior version. How to is in this prior post →

However, I’m a bit curious about your upload error since that usually indicates a server issue. Was that really at or somewhere else (a local server?).

Dear @jennaj ,
Thank you so much for this usefull information. Now I learnd how to restore it to the previous version. For your other question yes I am using However, I tried importing this workflow on different days but the result was the same. But I restored it, thanks.

1 Like