Problem with a package instalation


I’m trying to install Galaxy and in the first time I run sh I have this message:

“Cannot uninstall ‘certifi’. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.”

So, it doesn’t run.

I’ll appreciate any help.

Best regards,

1 Like

If still a problem…

  • Are you starting up Galaxy inside a virtualenv or ??
  • What is your source? A master release? Dev release? Docker image?

If resolved, what worked to resolve the install?

Help docs:

I installed Galaxy recently on top of Debian. No such an error. What is you Linux OS?
Did you try the to install certifi on you own before starting? May be this could help




Thank you Jenna and Sam. I deleted and start all over again and it works. Now it is running.

Only thing is that I need to run sh with sudo command, but it is not a big deal.

Now my problems are others, with some tools… heheh


1 Like

Please never run as sudo, among other things this is a big security issue.
There is clearly something wrong with your setup.
Basic instructions are at, if this doesn’t work feel free to post the complete error message here.


Hi Marius,
Having recently installed a server from scratch, may I suggest a few improvements in the documentation you pointed.
a) should state about a default user to install and launch the script. Maybe this information is in another part of the doc, but as it is the entry point I think this could be useful for newbie as me.
b) should state how to become a registered user. It will sound very obvious to you and any other Galaxy users, but being more a sys admin than a end user, I was looking for a command to create users before using Galaxy (as in Linux, mysql, postgresql… installations).
My two cents, indirectly related to the question of the OP.

1 Like


I follow exact these steps. Actually, I’ve made a full reinstall of my machine, from zero.

This time, after run git… galaxy was created in root, not under my user in home. Is that correct? If not, what should I do?

Again, it only runs with sudo. Without I receive this:
OSError: [Errno 13] Permission denied: ‘/galaxy/static/plugins/interactive_environments/neo/static’

Thank you for any help.

1 Like

From the path in your error, it doesn’t look as if you are cloning the Galaxy repository into your user home directory.

Important: Avoid moving a Galaxy install after running sh the first time. Start over instead by cloning Galaxy into the directory where you want it to be, or other problems will come up.

There are alternatives/choices for the exact install “how-to”, please see:

Well, I really don’t know what’s going on. I did exactly what is in the tutorials.

Ok, I will not move. Can I delete it?

I’ll try again to see if it clone to my user home directory.

But I still didn’t find the information about the need of sudo.


Well, I try again and now everything works. Installed in the right directory and running without sudo. I have no idea what’s going on.

Thank you!

1 Like

I’m not sure exactly what information is missing there, but you can click at the top of the site on “edit” and propose changes, this would be much appreciated.

1 Like